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What are XTensions?
XTensions are software modules that can add features to QuarkXPress ...
but, if you’ve bought this package, you already knew that. Anyway, this
set of XTensions works like all XTensions to QuarkXPress: When they’re
present in your QuarkXPress folder (or in the XTension subfolder) when
you launch QuarkXPress, each XTension adds features and functionality
to the standard QuarkXPress program.

(For more detailed information on XTensions and their general use, refer
to Appendix B of the 

 

QuarkXPress Reference Manual.)

Note: For information about the compatibility of the XTensions in this
package with various versions of QuarkXPress, see the product box.

What XTensions are included in this Package?
This package includes 15 XTensions. Here’s a summary:

XPert Loader
XPert Loader lets you create sets of selected XTensions (any XTensions,
not just ours) to load when you launch QuarkXPress. You’ve probably
gotten tired of dragging XTensions between folders at the Finder.
With XPert Loader, you can wrangle those XTensions into manageable
groups and apply them as needed. XPert Loader provides a familiar
style sheet-like interface.
See page 1.

XPert CharacterStyles
XPert CharacterStyles lets you create sets of character attributes (e.g., font,
size, type style, etc.) and apply them to selected text without having to
select and apply the attributes individually.
See page 7.
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XPert TextLink
XPert TextLink provides a palette that gives you several linking and
unlinking features not available in QuarkXPress, such as joining two or
more existing text chains (even if they contain text) and splitting a text
chain into smaller chains.
See page 29.

XPert TextStyler
XPert TextStyler adds a new tool to the QuarkXPress tool palette that lets
you select text by dragging a selection marquee around the text. XPert
TextStyler also gives you exacting control over the way character attrib-
utes and individual style sheet formatting are applied to selected text.
See page 47.

XPert Pilot
XPert Pilot provides a palette-based preview of the pages in the active
document that allows you to instantly go to any part of the current
spread with a click of the mouse. The XTension also lets you place
“markers” in documents that let you return to specified locations and
view percentages with a click of the mouse.
See page 57.

XPert CommandPad
XPert CommandPad lets you create your own custom palettes that allow
you to access any QuarkXPress function with a click of the mouse. The
palettes you create can contain tools, any menu command available in
QuarkXPress, and most keyboard combinations.
See page 67.

XPert Scripter
XPert Scripter lets you launch OSA-compliant AppleScript scripts from
within QuarkXPress. You can also group scripts in sets that, when acti-
vated, will run all the scripts in the set, one after the other. XPert Scripter
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also provides an easy method for naming items (i.e., text boxes, picture
boxes, lines) so that they can be easily located and modified by Apple-
Scripts. 
See page 77.

XPert Rulers
XPert Rulers provides two features that make working with page ele-
ments easier: 1) You can display floating rulers that snap to the items on
a page, allowing you to quickly create guides and align items. 2) The
Measure Tool finds the distance and angle between any two points.
See page 93.

XPert PageSets
XPert PageSets lets you save and apply document setup information
(size, columns, margins, and so on) in a manner similar to colors and
style sheets. These settings are saved as pagesets.
See page 101.

XPert ItemMarks
XPert ItemMarks lets you quickly create custom crop marks and registra-
tion targets around items. This is an especially useful feature for those
who need special crop marks and for those who prepare color work, as
QuarkXPress alone print marks only around spreads.
See page 105.

XPert BoxTools
XPert BoxTools adds several box-related commands that let you: 1) resize
a picture to fit a box, 2) resize a box to fit a picture, 3) change a text box
to a picture box (and vice versa), 4) set text insets for individual text box
edges, and 5) horizontally and vertically align an item on a page.
See page 109.
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XPert JobLog
XPert JobLog keeps track of many kinds of changes that were made to
documents, and who made them. The XTension also lets you name a
document at the time you create it and save a report of the document
history.
See page 113.

XPert TextScaleShift
XPert TextScaleShift displays a palette with controls that let you apply
horizontal/vertical scaling and baseline shift to highlighted text.
See page 115.

XPert Preferences
XPert Preferences provides preference sets that let you: 1) control the 
resolution of the picture preview created when you import a picture, 2)
customize the look of QuarkXPress interface components, and 3) specify
default measurement units for different areas of the program.
See page 117.

XPert Greeking
XPert Greeking lets you select individual pictures boxes for greeking. 
The picture in a box to which you apply greeking displays as a solid
gray color when the box is not selected.
See page 123.

Using this Manual
The manual covers all commands and techniques for the XTensions listed
above. The material presented here is written with the assumption that
you are already familiar with QuarkXPress and your Macintosh.

Menu commands are set in 

 

bold type.

The notation Item > XPert Scale indicates that the XPert Scale command
can be found in the Item menu.
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Installing XTensions
The XPert Tools installer can automatically place all 15 XTensions on your
hard disk drive, or you can have it load only those you select.

Quick Installation
To install all of XPert Tools Volume Two you’ll need about 2MB of 
available hard disk space.

1. Hold down the Shift key as you choose Restart from the Special
Menu; this will disable all extensions including any virus protection.

2. Insert the XPert Tools Volume Two disk and double-click the
XPert Tools Volume 2 Installer icon.

3. When the installation splash screen appears, click to continue.

4. Click Install to install all 15 XTensions into the XTension 
subfolder of your QuarkXPress folder on your hard disk drive.

If, for some reason, the installer cannot locate your copy of
QuarkXPress, you can do so manually by clicking Select Folder.

5. A dialog box asks for your name, organization, and serial number.
Enter the required information and click OK.

When the installation process is complete, a message appears
indicating that the installation was successful.

6. Click Quit to exit the installer and return to the Finder. Store your
XPert Tools Volume Two disk in a safe place and enjoy.

Custom Installation
1. Follow steps 1, 2, and 3 in the “Quick Installation.”

2. Click Custom Install. select individual items for installation and
click Install.

3. Follow steps 5 and 6 in the “Quick Installation.”

Installing Demonstration Versions
The dialog box displayed after you click Install provides a Demo button
that allows you to install unserialized, limited-function versions of the
XTensions. We included these demos to provide a sense of the benefits
available from XPert Tools. Feel free to share the installation disk (for
demos only!) with friends and co-workers.
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A Word From ALAP

About software copying
Remember: by using this software you have agreed to the software
license — please do not copy the product illegally. If you have multiple
copies of QuarkXPress and you would like to use this software with
them, a site license can be arranged.

Thank you
We extend to you our thanks for your support of this product. It is
important that you understand that a lowly apprentice production, inc.
is a small software company (nowhere near the size of Quark, Inc.). It is
your comments and feedback that lead to improvements to this product.
Please feel free to call or write with any suggestions you may have for
future versions of this XTension and we will put them on our “wish list.”

Also, if you encounter a problem with the software, please let us know
what you did and what the XTension did — only the problems we know
about can be fixed.

And finally, please be sure to send in your registration card so we can
keep you informed about what we are doing.

a lowly apprentice production, inc.
5963 La Place Court, Suite 206
Carlsbad, CA 92008-8823  USA

Voice: (619) 438-5790
Facsimile: (619) 438-5791

AppleLink: ALAP
CompuServe: 74742,2064
Internet: support@alap.com
America Online: ALAPOnline
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What Is XPert Loader?
The XPert Loader XTension lets you create sets of selected XTensions
to load when you launch QuarkXPress. You’ve probably gotten tired
of dragging XTensions between folders at the Finder. With XPert
Loader, you can wrangle those XTensions into manageable groups
and apply them as needed. XPert Loader provides a familiar style
sheet-like interface.

XPert Loader works by always loading first, allowing it to filter the load-
ing of subsequent XTensions. XPert Loader can find and selectively load
all XTensions that reside in the QuarkXPress folder and in the “XTen-
sion” subfolder.

Note: XPert Loader cannot look into the “Other XTension” folder created
by Quark to store unused XTensions. If you want XPert Loader to man-
age all of your XTensions, place them in the “XTension” folder.

What XPert Loader adds to QuarkXPress
XPert Loader adds one command to the QuarkXPress menus: Edit >
Preferences > XPert Loader.
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Creating and Editing XTension Sets
Choose Edit > Preferences > XPert Loader to display a dialog box that lets you
create and edit XTension sets. The XTension Sets dialog box is also displayed
the first time the XTension is run. Thereafter, you can specify whether it displays
automatically when you launch QuarkXPress.

XTension set scroll list
This scroll list displays all XTension sets that have been created. The
checkmark next to a set name indicates the set to be loaded when
QuarkXPress is launched.

To choose a different set, click in the blank column just to the left of the
set name. The checkmark displays next to the chosen set.

Two default sets are included: All On runs every XTension found in the
QuarkXPress folder and the XTension subfolder. All Off prevents all
XTensions from loading.

The display area below the scroll list shows all XTensions included in
the selected set.

New
To create a new XTension set, click New. Clicking New displays the Edit
XTension Set dialog box, which lists all available XTensions for you to
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include in the set. Using the Edit XTension Set dialog box to edit sets is
discussed on page 4.

Edit
To edit an existing XTension set, select the set in the scroll list and click
Edit (or double-click). Clicking Edit displays the Edit XTension Set 
dialog box, which lists all available XTensions for you to include in the
set. Using the Edit XTension Set dialog box to edit sets is discussed on
page 4. You can not edit All On or All Off.

Duplicate
To create a copy of an existing XTension set, select the set in the scroll
list and click Duplicate. Clicking Duplicate displays the Edit XTension
Set dialog box, which lists all available XTensions for you to include in
the set. Using the Edit XTension Set dialog box to edit sets is discussed
on page 4. You can duplicate All On or All Off.

Delete
To remove an existing XTension set, select the set in the scroll list and
click Delete. Shift-click and Command-click to select more than one set.
You cannot delete All On or All Off.

Quit
To quit QuarkXPress, click Quit. If the XTension Sets dialog box was
displayed on startup, no further XTensions will be loaded, and you will
be returned to the Finder. If you accessed the XTension Sets dialog box
via Edit > Preferences > XPert Loader to specify a new XTension set,
Quit is a quick way to restart QuarkXPress to run your new set.

Options
To open a dialog that lets you set various preferences for XPert Loader,
click Options.
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Activate Key
To specify the key(s) that lets you display the XTension Sets dialog box
when you launch QuarkXPress, even if you have set the preference for it
to not display, hold down the key(s) you want to use and click Activate
Key. You can use Command, Option, Control, and Caps Lock. For
example, if you specify the Option key, holding down the Option key as
you launch QuarkXPress will display XTension Sets.

Load New XTensions
To tell XPert Loader how to load XTensions placed in your QuarkXPress
folder or XTension folder after you have created your sets, choose an
option from the Load New XTensions pop-up menu.

With All Sets adds new XTensions to every set you’ve created. With
Current Set adds new XTensions to the active set only. Never keeps new
XTensions from being added to any existing sets, allowing you to add
XTensions manually to just those sets you want.

Display XPert Loader at Startup
Check this box to open the XTension Sets dialog box automatically
every time you launch QuarkXPress. This gives you the option to specify
a new XTension set for each session.

Editing XTension Sets
Clicking New, Edit, or Duplicate in the XTension Sets dialog box displays
the Edit XTension Set dialog box. You can also display this dialog box
by double-clicking an XTension set name.
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Name
Specify a name for the newly created or edited set. The name you assign
will be displayed in the XTension Sets dialog box scroll list.

XTension scroll list
This scroll list displays all available XTensions. Checked XTensions are
included in the current set, unchecked XTensions are not.

To include an XTension, click to the left of the XTension name to place a
checkmark next to the name. To remove an XTension, click on the check-
mark displayed to the left of the XTension name.

The area to the right of the scroll list displays information about the cur-
rently selected XTension. Information includes creation date, modifica-
tion date, and version information. This is the same information you
would obtain by choosing File > Get Info for the XTension at the Finder.

All On
To check all XTensions in the list so that they will load at launch time,
click All On.

All Off
To uncheck all XTensions in the list so that they will not be loaded at
launch time, click All Off.
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What is XPert CharacterStyles?
The XPert CharacterStyles XTension lets you create sets of character
attributes (e.g., font, size, type style, etc.) and apply them to selected text
without having to select and apply the attributes individually. These
sets — referred to as “attribute sets” — are similar to QuarkXPress style
sheets in that multiple attributes can be applied to text simultaneously.
But unlike QuarkXPress style sheets, which are applied to entire para-
graphs, you apply attribute sets to highlighted characters only.

Once you create an attribute set, it’s easy to apply complex text styling
with a single command. And, XPert CharacterStyles lets you edit
attribute sets so that you can make documentwide character attribute
changes to all similar text at once. Used alone, or in combination with
QuarkXPress style sheets, XPert CharacterStyles attribute sets can save
you hours of selecting and applying and changing character attributes.

What XPert CharacterStyles adds to QuarkXPress
XPert CharacterStyles adds three commands to the QuarkXPress menus.

• Edit > XPert CharacterStyles displays a dialog box that lets you
create, edit, and delete attribute sets.

• Style > XPert CharacterStyles lets you apply the attribute sets to text.

• View > Show/Hide CharacterStyles lets you display and hide the
XPert CharacterStyles palette, which lets you format text via customiz-
able “QuickMenus.” You can also use the palette to apply attribute
sets created using Edit > XPert CharacterStyles.

7
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What are Attribute Sets?
Text frequently has a number of character attributes applied to it. For
example, if you highlight a word, you might see that it is 11.5pt Wal-
baum Roman, tracked to -2, underlined, and blue. These styles are all
character attributes. Sets of character attributes — called attribute sets —
can be created and named using the Edit > XPert CharacterStyles and
subsequently applied to text. 

Like style sheets, attribute sets can be edited. When you edit an attribute
set — to change its specified point size from 11.5pt to 11.25pt, for example
— any text in a document that has the character attributes specified in
the attribute set are automatically reformatted to match the revised char-
acter attribute set specified in the attribute set. This includes any text to
which the attribute set has been applied (see Applying attribute sets on
page 14) and any text that has been formatted with local character attrib-
utes that exactly match those specified in the attribute set, whether the
attribute set has been applied to it or not.

Creating and Working with Attribute Sets
To create or edit an attribute set, choose Edit > XPert CharacterStyles.
The XPert CharacterStyles dialog box is displayed.

The controls of the 

 

XPert CharacterStyles dialog box will be familiar if you’ve used the
QuarkXPress Style Sheets dialog box. Don’t forget to click Save before you close the dia-
log box if you want to save the attribute sets you’ve created or appended and the edits
you’ve made to existing attribute sets.
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Attribute Sets scroll list
The scroll list displays the attribute sets you’ve created. When no docu-
ment is open, the list displays default attribute sets. When a document is
open, the list displays the attribute sets available for that document,
including default attribute sets and the attribute sets you created for the
open document.

Attribute sets you create when no documents are open are default
attribute sets; these are available to the new documents you subse-
quently create. Attribute sets you create when a document is open
belong to that document; these attribute sets are not available to other
documents unless you append them to another document. (See Append
below for more about appending attribute sets.)

New
To create a new attribute set click New. The XPert CharacterStyles dialog
box is displayed, which contains controls that let you create and edit
attribute sets. See Editing Attribute Sets on page 10 for more information.

Edit
To edit an attribute set, click Edit. The XPert CharacterStyles dialog box
is displayed. Use the controls in this dialog box to edit attribute sets. See
Editing Attribute Sets on page 10 for more information.

Duplicate
To create a copy of an attribute set, select it in the list and click Duplicate.
The XPert CharacterStyles dialog box is displayed, with the default
name “Copy of attribute set name.” You can edit this name and any of
the attributes using the dialog box controls. See Editing Attribute Sets on
page 10 for more information.

Delete
To delete an attribute set from the scroll list, select it in the list and click
Delete. Text that had an attribute set that you delete applied to it retains
its character formatting, but no longer is associated with any attribute set.

Append
To import attribute sets from another document, click Append. A dialog
box that lets you open the document whose attribute sets you want to
import is displayed. Use the dialog box controls to locate and select the
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document you want, then click Open. The attribute sets from the docu-
ment you selected will be added to the scroll list in the current document’s
XPert CharacterStyles dialog box. If you try to append an attribute set
with the same name as an attribute set that already exists in the current
document, the set is not appended to the current document.

Editing Attribute Sets
If you click New, Edit, or Duplicate in the XPert CharacterStyles dialog
box, the XPert CharacterStyles dialog box is displayed. All the attributes
you specify in the XPert CharacterStyles dialog box are applied to
selected to text when you apply the attribute set.

The XPert CharacterStyles dialog box is quite similar to the Character
Attributes dialog box in QuarkXPress (displayed by choosing Style >
Character). Some special controls have been added that are unique to
XPert CharacterStyles. These are discussed below. To learn more about
using the remaining controls, see the Character section in the Style
menu chapter of the QuarkXPress Reference Manual.

Name
To name or rename an attribute set, enter the name you want in the
Name field. The name you specify is displayed in the XPert Character-
Styles dialog box’s scroll list when you click OK.
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Keyboard Equivalent
To specify a Keyboard Equivalent for the attribute set, click on this field
to place the cursor, and press the key(s) you want. You can use a keboard
equivalent to apply an attribute set to selected characters without using
the XPert CharacterStyles submenu (Style menu) command or the
XPert CharacterStyles palette.

Script
The pop-up menu to the right of the Script check box in the Style area is
an XPert CharacterStyles addition. Choose Super to specify superscript;
choose Sub to specify subscript. This pop-up menu is available only
when Script is checked.

Underline
The pop-up menu to the right of the Underline check box in the Style
area is an XPert CharacterStyles addition. Choose All to apply the
underline style to all selected characters; choose Word to apply the word
underline style to all selected words. This pop-up menu is available only
when Underline is checked.

Caps
The pop-up menu to the right of the Caps check box in the Style area is
an XPert CharacterStyles addition. Choose All to specify all caps; choose
Small to specify small caps. This pop-up menu is available only when
Caps is checked.
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Applying Attribute Sets to Text
There are three methods of applying attribute sets to selected text: 1) using
the Style > XPert CharacterStyles, as discussed in this section, 2) clicking
the attribute set name you want to apply in the XPert CharacterStyles
palette, as discussed on page 14) using the keyboard command specified
as part of the attribute set in the XPert CharacterStyles dialog box.

Applying attribute sets from the Style menu
To apply an attribute set, select the text you want to modify, then choose
Style > XPert CharacterStyles. From the submenu, choose the attribute
set you want to apply.

Attribute sets behave like locally applied character formats in Quark
XPress. Applying an attribute set to selected characters within a para-
graph does not affect the character attributes of non-selected text or the
formats of the paragraph, including style sheets.

A note about attribute sets and locally applied character attributes
When the locally applied character attributes (those applied using the
commands in the top half of the Style menu) of text match EXACTLY
those specified in an attribute set, XPert CharacterStyles considers that
text to be of that attribute set.

If you edit an attribute set, all instances of text whose attributes match
the attribute set, regardless of whether the attribute set was applied to it,
will be changed to match the attribute set’s updated attributes. This can
be a very helpful feature, but can also be confusing if you aren’t mindful
of this when creating or editing an attribute set (and when applying
local character attributes).

Using XPert CharacterStyles to Format Text 
The following illustration shows a situation in which CharacterStyles
can speed repetitive character formatting tasks. The example shows text
formatted with attribute sets. By editing one of the attribute sets applied
to the text, you can change the formatting of similar text throughout the
entire document at once.
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The illustration shows an example of the kind of formatting attribute sets can make easier.
The paragraph was originally formatted by applying a style sheet, which supplied the para-
graph formats and character formatting for most of the text. Three attribute sets were then
applied: one was applied to the seven characters that make up the model number at the start
of the text block; the product name, “Multimedia Disk” received another attribute set. The
“Prices” attribute set was just applied to the price selected in the text box illustrated at left
by selecting the set from the XPert CharacterStyles palette (right). If a designer subse-
quently decides that all prices need to be horizontally scaled 125%, one simple change to
the “Prices” attribute set reformats every price in the document.

Using the XPert CharacterStyles palette
The XPert CharacterStyles palette lets you apply character attributes to
text in two ways.

The palette has six QuickMenus, which are configurable pop-up menus
that you can set up to display only the character formatting attributes you
want. Once you’ve added the attributes you want to the QuickMenus,
you can click on the menus’ pop-icons to choose and apply the attributes
to selected text. 

The palette also contains a scroll list that displays the names of the available
attribute sets. (The first half of this chapter discusses XPert CharacterStyles
attribute sets.) You can apply an attribute set to selected text by clicking
the attribute set you want in the palette’s scroll list.
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Applying attribute sets using the palette
The scroll list in the palette displays the names of the attribute sets avail-
able to the current document. If no attribute sets have been created, this
scroll list is blank. For more information about setting up attribute sets,
see Creating and Working with Attribute Sets on page 8.

To apply an attribute set, select the characters in your document you
want to format then click the attribute set name in the scroll list.

When selected characters contain all of the character attributes specified
in an attribute set, that attribute set is highlighted in the scroll list. This
is true whether the text was formatted using an attribute set or by the
standard QuarkXPress character formatting commands. If no attribute
set is highlighted in the list, either there is more than one attribute set
applied within the selected range or no attribute set is applied to the cur-
rent selection.

Using QuickMenus for fast character formatting
The XPert CharacterStyles palette provides six QuickMenus: font, size,
style, track, scale, and color.
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QuickMenus are configurable and editable, enabling you to create cus-
tom menus that display menu lists that contain only the character for-
matting commands that you frequently use.

In this illustration, three fonts have been added to the QuickMenu. Choosing Add
from  this or any of the other QuickMenus displays a dialog box that lets you add attrib-
utes to the menu, as described in the sections that follow.

The fonts QuickMenu, for example, can be set up to contain only the
fonts you need for a particular document: instead of repeatedly applying
a font to text by choosing it from the QuarkXPress Fonts submenu, you
can simply add that font to the palette’s font menu, then apply it easily
to selected text.

Another good use for QuickMenus is using them to list custom charac-
ter formatting values. Many of the QuarkXPress character attribute
menu commands list only a limited set of values from which you can
choose; these menus also usually list Other, which displays a dialog
box that lets you specify a custom value. Without XPert Character-
Styles, you would have to choose Other and enter a custom value each
time you want to make a formatting change. With the XPert Character-
Styles palette, you can add custom values — such as 9.5 point size and
92% horizontal scale — to the palette’s Font Size and Horizontal Scale
menus, so that these custom values can quickly be applied to selected
text, without having to enter values in dialog boxes.

Using the (Font) QuickMenu
The QuickMenu contains font names. This QuickMenu is especially
useful when you use fonts that you would have to access through the
Style > Font > FontFamily > FontName sub-sub-menu in QuarkXPress.

Adding fonts to the QuickMenu
To add a font to the XPert CharacterStyles palette’s font menu, click 
and choose Add from the pop-up menu. The Add Fonts dialog box is
displayed.
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The dialog box scroll list displays the names of all the fonts available to
QuarkXPress. Click to select the fonts you want to add. You can select
multiple fonts. Hold down the Command key and click in the list to
select individual fonts; hold down the Shift key and click to select a
range of fonts. Press Command-A to select all the fonts. Click OK to add
the fonts to the QuickMenu.

Document Only
To specify that the fonts you add be available to only the current docu-
ment, check Document Only. If Document Only is unchecked when
you add the fonts, the fonts you add will be added to the default set dis-
played in the QuickMenu in all documents, unless removed for a par-
ticular document (see Removing fonts from the QuickMenu, below, for
more information).

Removing fonts from the QuickMenu
To remove a font from the QuickMenu, hold down the Shift key
when you click the QuickMenu pop icon; the Add entry is replaced by
Remove. Choose Remove to display the Remove Fonts dialog box.
Select the fonts you want to remove and click OK.
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The Application and Document check boxes indicate whether default
and/or document specific fonts are displayed in the dialog box scroll
list. To display default fonts in the scroll list in this dialog box, check
Application. To display document fonts in the scroll list in this dialog
box, check Document. Unchecking the Application and/or Document
check boxes prevents default and/or document fonts from being dis-
played in this dialog box so that you cannot inadvertently select and
delete them. A grayed check box label indicates that no fonts of that type
have been added to the pop-menu.

Applying fonts from the QuickMenu
To apply a font that has been added to the QuickMenu, select the text
you want to reformat, then click and choose the font you want to
apply.
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Using the (Size) QuickMenu
The QuickMenu contains custom font sizes. You can add any acceptable
font size (from 2pt to 720pt, in .001 increments) to the QuickMenu.

Adding custom sizes to the QuickMenu
To add a font size to the XPert CharacterStyles palette’s size menu, click

and choose Add from the pop-up menu. The Add Size dialog box is
displayed. Enter the font size you want to add in the Size field and click
OK.

To specify that the font size you’re adding be available to only the current
document, check Document Only. If Document Only is unchecked when
you add the font size, the size you add will be added to the default set
displayed in the QuickMenu in all documents, unless removed for a
particular document (see Removing font sizes from the QuickMenu,
below, for more information).

Removing sizes from the QuickMenu
To remove a font size from the QuickMenu, hold down the Shift key
when you click the QuickMenu pop icon; the Add entry is replaced by
Remove. Choose Remove to display the Remove Sizes dialog box.
Select the size you want to remove and click OK.

The Application and Document check boxes indicate whether default
and/or document specific sizes are displayed in the dialog box scroll
list. To display default sizes in the scroll list in this dialog box, check
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Application. To display document sizes in the scroll list in this dialog
box, check Document. Unchecking the Application and/or Document
check boxes prevents default and/or document sizes from being dis-
played in this dialog box so that you cannot inadvertently select and
delete them. A grayed check box label indicates that no sizes of that type
have been added to the pop-menu.

Applying custom sizes from the QuickMenu
To apply a font size that has been added to the QuickMenu, select the
text you want to reformat, then click and choose the font size you
want to apply.

Using the (Style) QuickMenu
The QuickMenu lets you apply any or all of the nine QuarkXPress
style attributes. This QuickMenu lets you create attribute sets and add
the sets to the QuickMenu for applying to text.

Adding styles to the QuickMenu
To name and add a attribute set to the XPert CharacterStyles palette’s
style menu, click and choose Add from the pop-up menu. The Add
Style dialog box is displayed. Use the dialog box controls to select the
attributes you want the set to contain, enter a Name in the field, then
click OK.
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To specify that the attribute set you’re adding be available to only the
current document, check Document Only. If Document Only is unchecked
when you add the attribute set, the set you add will be added to the
default set displayed in the QuickMenu in all documents, unless
removed for a particular document (see Removing font sizes from the 
QuickMenu, below, for more information).

The Add Style dialog box is quite similar to the Character Attributes
dialog box in QuarkXPress (displayed by choosing Style > Character).
Some special controls have been added that are unique to XPert Character-
Styles. These are discussed below. To learn more about using the remain-
ing controls, see the Character section in the Style menu chapter of the
QuarkXPress Reference Manual.

Script
The pop-up menu to the right of the script check box is an XPert Character-
Styles addition. Choose Super to specify superscript; choose Sub to
specify subscript. This pop-up menu is available only when Script is
checked.

Underline
The pop-up menu to the right of the script check box is an XPert Character-
Styles addition. Choose All to apply the underline style to all selected
characters; choose Word to apply the word underline style to all selected
words. This pop-up menu is available only when Underline is checked.
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Caps
The pop-up menu to the right of the script check box is an XPert Character-
Styles addition. Choose All to specify all caps; choose Small to specify
small caps. This pop-up menu is available only when Caps is checked.

Removing styles from the QuickMenu
To remove an attribute set from the QuickMenu, hold down the Shift
key when you click the QuickMenu pop icon; the Add entry is replaced
by Remove. Choose Remove to display the Remove Styles dialog box.
Select the attribute set you want to remove and click OK.

The Application and Document check boxes indicate whether default
and/or document specific styles are displayed in the dialog box scroll
list. To display default styles in the scroll list in this dialog box, check
Application. To display document styles in the scroll list in this dialog
box, check Document. Unchecking the Application and/or Document
check boxes prevents default and/or document styles from being dis-
played in this dialog box so that you cannot inadvertently select and
delete them. A grayed check box label indicates that no styles of that
type have been added to the pop-menu.

Applying styles from the QuickMenu
To apply an attribute set that has been added to the QuickMenu,
select the text you want to reformat, then click and choose the
attribute set you want to apply.
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Using the (Kern/Track) QuickMenu
The QuickMenu contains custom track values. You can add any
acceptable track value (from -500 to 500, as measured in 200ths of an em
space, in .001 increments) to the QuickMenu. When the selected text
contains a range of characters, the selected characters will be tracked
when you apply a QuickMenu value. If the cursor is between two
characters, applying a value from the QuickMenu will kern the char-
acter pair.

Adding custom track values to the QuickMenu
To add a track value to the XPert CharacterStyles palette’s track menu,
click and choose Add from the pop-up menu. The Add Track dialog
box is displayed. Enter the track value you want to add in the Track
field and click OK. Negative values are displayed in parentheses in the
pop-up menu.

To specify that the track value you’re adding be available to only the
current document, check Document Only. If Document Only is
unchecked when you add the track value, the value you add will be
added to the default set displayed in the QuickMenu in all docu-
ments, unless removed for a particular document (see Removing custom
track values from the QuickMenu, below, for more information).

Removing custom track values from the QuickMenu
To remove a track value from the QuickMenu, hold down the Shift
key when you click the QuickMenu pop icon; the Add entry is replaced
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by Remove. Choose Remove to display the Remove Tracks dialog box.
Select the track value you want to remove and click OK.

The Application and Document check boxes indicate whether default
and/or document specific track values are displayed in the dialog box
scroll list. To display default track values in the scroll list in this dialog
box, check Application. To display document track values in the scroll
list in this dialog box, check Document. Unchecking the Application
and/or Document check boxes prevents default and/or document track
values from being displayed in this dialog box so that you cannot inad-
vertently select and delete them. A grayed check box label indicates that
no track values of that type have been added to the pop-menu.

Applying custom track values from the QuickMenu
To apply a track value that has been added to the QuickMenu, select
the text you want to reformat, then click and choose the track value
you want to apply. 

When the selected text contains a range of characters, the selected char-
acters will be tracked when you apply a QuickMenu value. If the cur-
sor is between two characters, applying a value from the QuickMenu
will kern the character pair.

23

XPE R T CH A R A C T E RST Y L E S



Using the (Scale) QuickMenu 
The QuickMenu contains custom scale values. You can add any
acceptable horizontal or vertical scale value (from 10% to 400%, in .001
increments) to the QuickMenu. 

Adding custom scale values to the QuickMenu
To add a scale value to the XPert CharacterStyles palette’s Scale menu,
click and choose Add from the pop-up menu. The Add Scale dialog
box is displayed. 

To specify the scale, choose Horizontal or Vertical from the Scale pop-up
menu, then enter the scale value you want in the Scale field and click OK.

To specify that the scale value you’re adding be available to only the
current document, check Document Only. If Document Only is
unchecked when you add the scale value, the value you add will be
added to the default set displayed in the QuickMenu in all docu-
ments, unless removed for a particular document (see Removing custom
scale values from the QuickMenu, below, for more information).

Removing custom scale values from the QuickMenu
To remove a scale value from the QuickMenu, hold down the Shift
key when you click its pop icon; the Add entry is replaced by Remove.
Choose Remove to display the Remove Scales dialog box. Select the
scale value you want to remove and click OK.
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The Application and Document check boxes indicate whether default
and/or document specific scale values are displayed in the dialog box
scroll list. To display default scale values in the scroll list in this dialog
box, check Application. To display document scale values in the scroll
list in this dialog box, check Document. Unchecking the Application
and/or Document check boxes prevents default and/or document scale
values from being displayed in this dialog box so that you cannot inad-
vertently select and delete them. A grayed check box label indicates that
no scale values of that type have been added to the pop-menu.

Applying custom scale values from the QuickMenu
To apply a scale value that has been added to the QuickMenu, select
the text you want to reformat, then click and choose the scale value
you want to apply.

An “H” or “V” follows scale entries in the pop-up menu to indicate whether the scale
value is a horizontal scale or a vertical scale.

Using the (Color) QuickMenu 
The QuickMenu contains custom colors and shades. You can add any
of the colors in the document’s color palette, with shading specifications,
to the QuickMenu. With standard QuarkXPress tools you must first
apply a color to text, then apply a shade value to it. The QuickMenu
lets you apply both attributes to text at once from a convenient location.

A color must be part of the document’s color palette before you can add
it to the QuickMenu. You add colors to the QuarkXPress palette by
creating colors using the controls in the Colors dialog box (Edit >
Colors).

Adding colors and shades to the QuickMenu
To add a color and shade to the XPert CharacterStyles palette’s Color
menu, click and choose Add from the pop-up menu. The Add Color
dialog box is displayed. 
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To specify the color, choose one from the Color pop-up menu, then enter
the shade value you want in the Shade field. Click OK to add the color
and shade to the pop-menu.

To specify that the color and shade you’re adding be available to only
the current document, check Document Only. If Document Only is
unchecked when you add the color and shade, the color and shade you
add will be added to the default set displayed in the QuickMenu in
all documents, unless removed for a particular document (see Removing
custom colors and shades from the QuickMenu, below, for more infor-
mation).

Removing custom colors and shades from the QuickMenu
To remove a color and shade from the QuickMenu, hold the Shift key
when you click its pop icon; the Add entry is replaced by Remove.
Choose Remove to display the Remove Colors dialog box. Select the
color and shade you want from the scroll list and click OK to remove it
from the QuickMenu.

The Application and Document check boxes indicate whether default
and/or document specific colors and shades are displayed in the dialog
box scroll list. To display default colors and shades in the scroll list in
this dialog box, check Application. To display document colors and
shades in the scroll list in this dialog box, check Document. Unchecking
the Application and/or Document check boxes prevents default and/or
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document colors and shades from being displayed in this dialog box so
that you cannot inadvertently select and delete them. A grayed check
box label indicates that no colors and shades of that type have been
added to the pop-menu.

Applying custom colors and shades from the QuickMenu
To apply a color and shade that has been added to the QuickMenu,
select the text you want to reformat, then click and choose the color
and shade you want to apply.

Note: All scroll lists in the dialog boxes used for adding and removing
items from QuickMenus, as discussed in the sections above, allow you
to enter Command-A to select all the items in the list. Scroll lists also
support keyboard look-up of list entries (i.e., entering the first few char-
acters of an item’s name to select it in the scroll list), and use of the page
up, page down, home, and end keys to scroll up and down the list. You
can also select multiple list items by holding down the Command key
and clicking in the list to select individual list items; hold down the Shift
key and click to select a range of list items. 
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What is XPert TextLink?
The XPert TextLink XTension provides a palette that gives you several
linking and unlinking features not available in QuarkXPress, such as:

• joining two or more existing text chains (even if they contain text)

• easily creating a series of linked text boxes

• splitting a text chain into smaller chains

• duplicating or deleting a text box containing text

• “Smart Paragraph” sensing that will retain the proper appearance of
text when chains are split or boxes unlinked.

What XPert TextLink adds to QuarkXPress
XPert TextLink adds one command to the QuarkXPress menus: View >
Show/Hide XPert TextLink lets you show and hide the XPert TextLink
palette.

The XPert TextLink Palette
Choosing View > Show XPert TextLink displays the XPert TextLink
palette with twelve linking/unlinking options in button form. You can
move and close this palette like other QuarkXPress palettes.

The buttons are divided into four task groups. The available buttons are
determined by what kinds of text boxes are active in the document.

29

XPE R T TE X TL I N K



• The two left buttons of the top row perform standard linking tasks.
Link to the Next Selected Box
Link to the Next Selected Chain

• The remaining four buttons of the top row let you split an existing
chain into multiple chains.
Split Text Chain at the Selected Box
Split Text Chain at the Selected Box using “Smart Paragraphs”
Split Text Chain at the Selected Box, Split Text from Insertion Point
Split Text Chain at the Selected Box, Split Text from Insertion Point
Using Smart Paragraphs 

• The three left buttons of the bottom row let you unlink all text boxes in
a chain.
Unlink All Boxes, Retain Text in First Text Box
Unlink All Boxes, Retain Text in Each Text Box
Unlink All Boxes, Retain Text in Each Text Box, Use Smart Paragraphs

• The remaining three buttons of the bottom row let you duplicate or
delete text boxes in a chain.
Duplicate Text Box and Contents
Duplicate Text Box and Contents, using Smart Paragraphs
Delete Text Box and Contents
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Tips
• Important Note: The Edit > Undo command is not available with XPert

TextLink. Save your work before using XPert TextLink, then if necessary,
use File > Revert to Saved to reverse an undesirable linking action.

• The XPert TextLink palette supports System 7 balloon help. Should you
forget the task a XPert TextLink button performs, choose Show Balloons
from the Help menu in the upper right corner of your screen and place
the current cursor over the XPert TextLink button in the palette.
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Link to the Next Selected Box (1st row, 1st button from left)
Use this button to link two text boxes, regardless of whether they con-
tain text or are part of an existing chain. For example, imagine you want
to link active text box (Box A) to a second text box (Box B). With Box A
active, click on this button and then click on Box B. Box A is now linked
to Box B.

Using this button you can automatically link text boxes as you create
them. To do so, begin by locking the Text Box tool in the QuarkXPress
Tool palette by selecting it with the Option key held down. After drag-
ging out your first text box, click and then drag out another text box.
The new text box is automatically linked to the first one. Repeat this pro-
cedure for each new text box you draw.

The next text box created will be automatically linked to text box C.

If, when using this button to link two existing text boxes, the next box
selected contains text, and is part of an existing text chain, it will be
removed from its existing chain, made part of a new chain, and the text
it originally contained with be taken from the first chain and appended
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to the end of the new chain. For example, Box Z is active and pressed.
Box B, of text chain A + B + C, is the next box selected. Box B now
becomes the second box in the chain Z + B and the text previously in
Box B is now in Box Z (the first box in the chain). The A + B + C chain is
now A + C with the text of Box C now linked after the text of Box A.

Note that the text from just Box B is placed in the new chain. The A + C chain
text now has a gap where the Box B text was.
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Link to the Next Selected Chain (1st row, 2nd button from left)
Use this button to combine two existing text chains into one text
chain. Take the example of two text chains: A + B + C and X + Y + Z.
With Box Z active, click and then select any of the text boxes in the
A + B + C chain. The two chains are combined with the contents of
the A + B + C chain appending to the end of the X + Y + Z chain. 

Note: If you want to keep the paragraph formats of the first paragraph of
the A + B + C chain, be sure to end the X + Y + Z chain with a return.
(Other wise the first paragraph of the old A + B+ C chain will become
part of, and take on the formats of, the last paragraph in X + Y + Z.)

Notice that the text from the
A+B+C chain now begins at
the bottom of Box Z.
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Split the Text Chain at the Selected Box (1st row, 3rd button from left)
Use this button to split an existing text chain into two chains, with the
second chain starting at the selected box, while retaining the contents
of that box. Take the example of text chain A + B + C + D. With Box C
active, click . The chain is now divided into two chains, A + B and
C + D, with the contents of Box C as the start of the second chain.

Note that the first line indent format of the paragraph straddling Box B
and Box C of text chain A + B + C + D, is now applied to the first para-
graph in Box C of the chain C + D.

The first paragraph of
the new chain C+D
displays the first line
indent of the paragraph
that had straddled
boxes B and C.
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Split the Text Chain at the Selected Box using Smart Paragraphs
(1st row, 4th button from left)
Use this button to split an existing text chain into two chains, using
XPert TextLink “Smart Paragraph” sensing. “Smart Paragraph” sensing
ignores the first line indent and drop cap formats of the paragraph
straddling two boxes and instead maintains the original look of the text
in the first text box of the newly created chain.

Take the example of text chain A + B + C + D. With Box C active, click
. The chain is now divided into two chains, A + B and C + D, with the

contents of Box C as the start of the second chain.

Note that with the use of the “Smart Paragraph” feature, the first line
indent format of the paragraph straddling Box B and Box C of text chain
A + B + C + D, is not applied to the first paragraph in Box C of the chain
C + D (as it would have been if you had used the Split the Text Chain at
the Selected Box button described on the previous page).
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The text chain is split, but the first paragraph of the newly created second chain does not
take on the indent or drop cap formats of the last paragraph in the previous chain.

“Smart Paragraphs” sensing sets the first line indent and drop caps for-
mats to zero, while retaining the other paragraph formats such as
hyphenation, justification, space before, space after, left indent, and right
indent, of the original paragraph.

Note that if the split paragraph was justified, XPert TextLink places a
Shift-Return after the last character of the first chain, to ensure the justi-
fied look. An overflow character will appear at the bottom of the text box.
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Split Text Chain at the Selected Box, Split Text from Insertion Point
(1st row, 5th button from left)
Use this button to split an existing text chain into two chains, with the
second chain starting at the selected box, but the text split starting at the
insertion point. The insertion point can be in any box in the chain. 

Take the example of text chain A + B + C + D. With the Content tool
selected, the insertion point is placed before the drop cap in Box B. With
the Item tool selected, click on Box C to make it active. Then click .
The chain is now divided into two chains, A + B and C + D, with the text
from the insertion point onward at the top of Box C.

(Even though the text insertion point no longer displays after you select
the Item tool and activate another box, XPert TextLink “remembers”
where it is.)

Note that the drop cap format of the paragraph straddling Box B and
Box C of text chain A + B + C + D, is now applied to the first paragraph
in Box C of the chain C + D.
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Split Text Chain at the Selected Box, Split Text from Insertion Point
Using Smart Paragraphs (1st row, 6th button from left)
Use this button to split an existing text chain into two chains, with the
second chain starting at the selected box, but the text split starting at the
insertion point, retaining the look of original chain. The insertion point
can be in any box in the chain. The text retains the look of the text in the
box at the start of the new chain.

Take the example of text chain A + B + C + D. With the Content tool
selected, the insertion point is placed before the word “XPert” in Box B.
With the Item tool selected, click on Box C to make it active. Then click

. The chain is now divided into two chains, A + B and C + D, with the
text from the insertion point onward at the top of Box C.

Note that the drop cap format of the paragraph straddling Box B and
Box C of text chain A + B + C + D, is not applied to the first paragraph in
Box C of the chain C + D.

With smart paragraphs. Without smart paragraphs.
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Unlink All Boxes, Retain Text in First Text Box
(2nd row, 1st button from left)
Use this button to unlink all text boxes in a chain while retaining the text
of the original chain in the first text box.

Take the example of text chain A + B + C + D. With any text box in the
chain active, click . All the text boxes are unlinked from the original
chain and the text is now contained in Box A, which displays an over-
flow character.
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Unlink All Boxes, Retain Text in Each Text Box
(2nd row, 2nd button from left)
Use this button to unlink all text boxes in a chain while retaining the text
in each text box of the original chain.

Take the example of text chain A + B + C + D. With any text box in the
chain active, click . All the text boxes are unlinked from the original
chain retaining the text each box originally contained. Note that in Box C,
the drop cap and first line indent formatting of the straddling paragraph
has been applied to the first character in Box C.

Notice the drop cap and indent applied to
the second half of the paragraph that strad-
dled boxes B and C.
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Unlink All Boxes, Retain Text in Each Text Box, Use Smart Paragraphs
(2nd row, 3rd button from left)
Use this button to unlink all text boxes in a chain while retaining the text
in each text box of the original chain. Text also retains its original
appearance.

Take the example of text chain A + B + C + D. With any text box in the
chain active, click . All the text boxes are unlinked from the original
chain retaining the text each box originally contained. The text keeps the
appearance of the text in the original chain.

Notice that the drop cap and first line indent
are not applied to the second half of the para-
graph that straddled boxes B and C.
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Duplicate Text Box and Contents
(2nd row, 4th button from left)
Use this button to duplicate a box, and only the text that it contains,
even though the box is part of a chain.

Take the example of text chain A + B + C + D. With Box C selected, click
. The text box and its contents are duplicated. 

Note that if you use the standard Copy command from the Edit menu,
the box will be duplicated, but the duplicate will contain the remaining
text to the end of the chain. This button only copies the text contained in
the duplicated text box.

Also note, that the drop cap and first line indent formatting of the strad-
dled paragraph is applied to the first character in the duplicated text
box. The original text chain is unaffected.
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Duplicate Text Box and Contents, using Smart Paragraphs
(2nd row, 5th button from left)
Use this button to duplicate a box, and only the text that it contains,
even though the box is part of a chain. Text also retains its original
appearance.

Take the example of text chain A + B + C + D. With Box C selected, click
. The text box and its contents are duplicated. 

Also note, the drop cap and first line indent formatting of the straddled
paragraph is not applied to the first character in the duplicated text box.
The duplicated text retains its original appearance. The original text
chain is unaffected.
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Delete Text Box and Contents
(2nd row, 6th button from left)
Use this button to delete a box and the text it contains from a chain.

Take the example of text chain A + B + C + D. With Box C selected, click
. The text box and its contents are deleted from the chain. 
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What is XPert TextStyler?

 

XPert TextStyler 

 

provides a flexible, alternative method of selecting and
working with text. XPert TextStyler adds a new tool to the QuarkXPress
tool palette that lets you select text by dragging a selection marquee
around the text you want to work on. Once text is selected, XPert
TextStyler lets you modify the text by automatically displaying a dialog
box that groups character attribute controls, making it easy to apply
numerous attributes to the selected text. XPert TextStyler also lets you
selectively apply the paragraph, character, tabs, or rule information con-
tained in a style sheet to selected text, and to replace style sheets applied
to paragraphs within selected text.

Unlike the text selection controls in QuarkXPress, which only let you
make contiguous text selections (i.e., a range of characters), XPert
TextStyler’s unique design lets you select and modify text within a mar-
quee selection area you draw using the TextStyler tool. Also, the
TextStyler tool lets you draw a marquee across more than one text box to
select text contained in multiple boxes; it is not possible to select text in
multiple boxes with QuarkXPress alone.

Selecting text is only the first part of the process. Once you drag a mar-
quee around a portion of a spread that contains text, XPert TextStyler
displays a dialog box that lets you apply character attributes using a
number of different methods:

• By applying character attributes you select in the dialog box.

• By selectively applying the paragraph formatting, character attributes,
tab specifications, and/or paragraph rule information contained in a
style sheet.

• By applying a XPert CharacterStyles attribute set.

You can also apply the previously applied set of character attributes to
text without displaying the 

 

XPert TextStyler dialog box. (see Quick
Apply on page 54.)
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What XPert TextStyler adds to QuarkXPress
XPert TextStyler adds a tool to the QuarkXPress Tool palette. The TextStyler tool
lets you marquee text selections. When you use the TextStyler tool to select text,
a dialog box is automatically displayed that lets you simultaneously apply mul-
tiple character attributes to the selected text.

The TextStyler tool (circled in the illustration) is displayed in the QuarkXPress Tool
palette when XPert TextStyler is installed.

Using the TextStyler Tool to Select Text and Apply Attributes
To apply character attributes to text using the TextStyler tool, first select
the tool in the QuarkXPress Tool palette. Drag out a marquee area
around the text you want to modify. 

The TextStyler tool lets you select text by dragging a marquee around the characters you
want to modify, and to apply multiple attributes to the selected characters at one time. 

When you’ve made your selection, the XPert TextStyler dialog box is
displayed.

Note: As with the other tools in the QuarkXPress Tool palette, if you
hold the Option key when selecting the TextStyler tool, it will remain
selected until you select another tool. 
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The 

 

XPert TextStyler dialog box is displayed when you make a text selection using the
TextStyler tool.

Use the controls in the XPert TextStyler dialog box to select the character
attributes you want applied to the text, selected by the TextStyler tool.

The illustration above shows the text, selected in the example on the previous page, after
the attributes selected in the XPert TextStyler dialog box (shown above) were applied.

Using the XPert TextStyler dialog box
When you use the TextStyler tool to select text, the XPert TextStyler dia-
log box is displayed immediately. The XPert TextStyler dialog box con-
tains the standard character attribute commands found in the Style
menu, as well as other controls that provide enhanced character format-
ting capabilities.
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The XPert TextStyler dialog box contains two areas: Character Attrib-
utes and Style Sheet. Each area has a radio button that lets you enable
or disable the controls in that area. Only one area can be active at a time,
which means you make selections in either the Character Attributes or
Style Sheet area, but not both.

Note: If text is highlighted (using the QuarkXPress Content tool) before
you use the TextStyler tool to select text, the controls in the XPert
TextStyler dialog box are preset to match the attributes applied to the
highlighted text.

Choosing character attributes
To modify the attributes in the Character Attributes area and apply
character attributes to the selected text, click Character Attributes. The
area’s controls become active.
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The Character Attributes area is quite similar to the Character Attributes
dialog box in QuarkXPress (displayed by choosing Style > Character).
Some special controls have been added that are unique to XPert
TextStyler. These are discussed below. To learn more about using the
remaining controls, see the Character section in the Style menu chapter
of the QuarkXPress Reference Manual.

Style
To apply type style attributes to selected text, check Style to enable the
individual attributes in the Style area. When the Style check box is
unchecked, the individual style attributes are dimmed and will not be
applied to the selected text.

When Style is checked, the pop-up menu to the right of the text box lets
you choose the way in which the style attributes in the Style area are
applied to the currently selected text. To add the styles you check to the
attributes already applied to the currently selected text, choose Append
from the pop-up menu. To replace the attributes already applied to the
currently selected text with the style attributes you check, choose
Replace from the pop-up menu.

For example, to apply the bold type style to selected text, check Bold.
This attribute will be applied to selected text according to the selection
you make in the Style pop-up menu (Append or Replace).

Script, Underline, Caps
The pop-up menus to the right of the Script, Underline, and Caps check
boxes provide appropriate options for each attribute. These pop-up
menus are available only when the associated check box is selected.
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Base on Style Sheet
To apply the character attributes contained in a style sheet to selected
text, choose a style sheet from the Base on Style Sheet pop-up menu.

When you choose a style sheet from the pop-up menu, the XPert TextStyler
dialog box is updated to display the character attributes specified in that
style sheet. You can specify additional attributes or disable the attributes
specified by the style sheet. Because style sheets contain paragraph for-
matting information as well as character attribute specifications, using
Base on Style Sheet can be especially useful when you want to apply
only the character attributes contained in a style sheet to selected text,
without having to apply paragraph formats as well.

Base on XPert Styles
To apply an attribute set — a set of character attributes that can be applied
to text simultaneously, which you can create using the XPert Character-
Styles XTension — to selected text, choose the attribute set you want
from the Base on XPertStyle pop-up menu. The XPert CharacterStyles
XTension, included in this package, is discussed on page 7.

When you choose an attribute set from the pop-up menu, the XPert
TextStyler dialog box is updated to display the character attributes speci-
fied in that set. Assuming you don’t make additional attribute selections
or disable any of the selections specified by the selected attribute set,
applying an attribute set to text using the XPert TextStyler dialog box
has the same effect as applying the attribute set using the controls pro-
vided by XPert CharacterStyles.

Specifying style sheet information
To modify any of the attributes in the Style Sheet area and apply style
sheet information to the selected text, click Style Sheet. The area’s con-
trols become active.

To specify the style sheet you want to apply to selected text, choose one
from the Style Sheet pop-up menu. The pop-up menu lists all style
sheets available to the current document.
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Override Style Sheet
To apply a style sheet to the paragraphs included in the text selection, check
Override Style Sheet. This check box is active only when the Paragraph, 
Character, Tabs, and Rules check boxes are all checked. When you override
style sheet information, the style sheet selected in the pop-up menu is applied to
all the paragraphs included in the text selection. Because style sheets are applied
to entire paragraphs, even paragraphs with only a few characters included in the
text selection are formatted with the new style sheet.

XPert TextStyler applies No Style before applying the style sheet selected in the
Style Sheet pop-up menu. This means that all local character and paragraph
formats in selected paragraphs will be replaced when XPert TextStyler applies
the style sheet.

Paragraph
To specify that the paragraph formatting specified in the selected style sheet are
applied to selected text, check Paragraph.

Character
To specify that the character attributes specified in the selected style sheet are
applied to selected text, check Character.

Tabs
To specify that the tab formatting specified in the selected style sheet are applied
to selected text, check Tab.

Rules
To specify that the paragraph rules specified in the selected style sheet
are applied to selected text, check Rules.
Note: Because Paragraph, Tabs, and Rules are formats applied to entire
paragraphs, even paragraphs only partially within the TextStyler selec-
tion will be reformatted when one of these is checked.

Applying selected attributes to text
To apply the character attribute specifications you select, click OK.

XPert TextStyler also provides two alternative methods for applying
formats: “Constrained Apply” and “Quick Apply.”
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Constrained Apply
To constrain the selected text so that the selection area keeps its original
shape when the new formats are applied, hold down the Control key
before releasing the mouse button when drawing the selection marquee. 

When Constrained Apply is used, XPert TextStyler will attempt to keep
the selected text within the shape of the original selection marquee. Note
the word “attempt.” Depending on the position and formatting of other
page elements, XPert TextStyler is not always able to maintain the exact
shape, but it does the best it can.

In this illustration, the top example shows the selection marquee. The middle example shows
the effect of applying attributes to selected text without constrain applied. The bottom exam-
ple shows how XPert TextStyler handled the same text selection with constrain applied.

Quick Apply
To apply the Text Styler attributes applied to the previously selected
text, hold down the Option key before releasing the mouse button when
drawing the selection marquee. The XPert TextStyler dialog box will not
be displayed, but the Text Styler attributes applied to the previously
selected text will be applied to the current selection.
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TextStyler at work
The following example shows a chart used in a publication. The top
example shows a column of text being selected with the TextStyler tool.
The illustration below shows the result of applying the bold attribute
and a new color to the column’s text using XPert TextStyler.
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What is XPert Pilot?
The XPert Pilot XTension provides a palette-based preview of the pages
in the active document that allows you to instantly go to any part of the
current spread with a click of the mouse. The XTension also lets you
place “markers” in documents that let you return to specified locations
and view percentages with a click of the mouse.

The XPert Pilot palette displays a preview of
the current page or spread on which you can
click to scroll the document.

What XPert Pilot adds to QuarkXPress
XPert Pilot adds one command to the QuarkXPress menus: View >
Show/Hide XPert Pilot.

• The View > Show/Hide XPert Pilot command displays the 
XPert Pilot palette.
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Using the XPert Pilot Palette
To display the XPert Pilot palette, choose View > Show XPert Pilot.
When the XPert Pilot palette is open, the View menu displays Hide
XPert Pilot. You can also display the palette by pressing the “Come”
modifier key(s) and clicking anywhere in the active document window.
See the discussion of these keys on page 64.

The XPert Pilot palette provides a number of features that you can use to quickly move
through documents.

If you want, the XPert Pilot preview can be updated periodically as you
work; you can set the length of time between automatic updates in the
XPert Pilot Preferences dialog box. You also can update the preview at
any time by clicking the button in the palette.

Note: Depending on the complexity of a spread, a second or two may be
required to create or update the XPert Pilot preview.
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The red flag in the preview is the You are here indicator; it moves
when you click elsewhere on the palette. You can also drag the mouse
on the preview; the document will scroll in the document window.

The Palette Controls

Scrolls the document up one spread. Hold down the Option key
and click to display the first page of the document.

Scrolls the document down one spread. Hold down the Option key
and click to display the last page of the document.

To add, select, and remove markers that you can use to quickly
return to certain document locations and views, click to display
the Marker pop-up menu.

The bottom of the Marker pop-up menu displays user-defined markers.

To add a marker for the current page position and view percent-
age, choose Add Marker from the pop-up menu. The Add Docu-
ment Marker dialog box is displayed.

Enter a name for the marker in the Name field and click OK. The
new marker is added to the pop-up menu.

To remove a marker from the pop-up menu, hold down the Shift
key and display the Marker pop-up menu. The menu commands
let you remove an individual marker or remove all markers.
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Manually updates the preview displayed in the palette. 

To change the document view percentage, click to display the
Magnification pop-up menu. Notice that the values in the menu
let you zoom to many times the maximum allowed by Quark
XPress itself.

To switch to one of the numeric document magnification values,
choose a value from the pop-up menu.

To view a document in the Thumbnails view, choose Thumbnails
from the pop-up menu.

To view a document in the Fit In Window view, choose Fit in
Window from the pop-up menu.

To go to a different page in the active document, click to display
the Go To Page pop-up menu and choose the page. The pop-up
menu displays document and master pages. When a master page
is displayed in the document window, the page numbers in the
pop-up menu are replaced with Document; choose this to return
to document pages.

Click the Jump button to move back and forth between the current
location and view and the previous red-flag location.

To display a pop-up menu that lets you scroll though the docu-
ment, update the preview, and display the XPert Pilot Preferences
dialog box, click .

To update the preview manually, choose Refresh Preview.

To scroll the document to the next or previous page, spread, or
section, choose one of the six scrolling options.

To save the palette’s current position as the “home” position,
choose Save Palette Position. You can subsequently return the
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palette to this location quickly by holding down the “Home” keys
specified in the XPert Pilot Preferences dialog box and clicking
anywhere on the palette.

To display the XPert Pilot Preferences dialog box, which contains
several controls for customizing the display and function of the
palette, choose Preferences.

For information about the controls in this dialog box, see Setting
XPert Pilot Preferences below.

Setting XPert Pilot Preferences
Choosing Preferences from the pop-up menu in the palette lets you
specify the way the preview displays in the XPert Pilot palette and vari-
ous keyboard combinations for the palette.

Preview
To specify the way in which document page previews display in the
XPert Pilot palette, use the control in the Preview area.

Inset
To specify the margins between the page preview and the nearest edges
of the view area, enter a value in the Inset field. Note that larger inset
values will decrease the size of the preview display to allow for the
increased margin. You can increase the size of the palette to increase the
size of the preview.
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Refresh Seconds
To specify the length of time between automatic preview updates, enter
a value in the Refresh Seconds field. This means that as the design of
the page changes, the XPert Pilot palette will automatically reflect those
changes. To disable this feature, uncheck the Automatic check box.

Even when you have specified periodic automatic updates, you can still
update the display of the palette manually by clicking the button in
the palette.

Text
To display the contents of text boxes in the preview, check Text. When
Text is unchecked, text box outlines, text, and the contents of anchored
boxes are not displayed.

Lines
To display lines in the preview, check Lines. When Lines is unchecked,
lines created with the QuarkXPress line tools are not displayed.

Pictures
To display the contents of picture boxes in the preview, check Pictures.
When Pictures is unchecked, picture box outlines and their contents are
not displayed.

Color
To display any color page elements in the appropriate colors in the page
preview, check Color. Otherwise, all elements are displayed as black
and white.
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Outlines
To display only the outlines of each of the elements on a page, check
Outlines. Outlines are not displayed for item types that are unchecked
in the Preview area (i.e., Text, Lines, or Pictures). Note that outlines of
anchored items are shown as well.

The illustration at left shows of the outline preview
of one of these documentation pages.

Automatic
To allow the palette to automatically update its display using to the
interval entered in the Refresh Seconds field, check Automatic. When
this control is unchecked, you can update the display of the palette
manually by clicking the button in the palette.

Show X/Y Coordinates
To display the coordinates of the pointer at the top of the palette when
you click or drag on the preview, check Show X/Y Coordinates.

Display “You are here” flag
To place a small red flag in the palette that indicates your current loca-
tion when you click or drag on the palette preview, check Display
“You are here” flag.

Minimize Palette upon Resize
To minimize the amount of screen real estate the palette takes up when
you resize the palette, check Minimize Palette upon Resize. For exam-
ple, if you have a two-page spread in the palette and you resize the
palette to be taller than it is wide, this control will automatically snap the
palette size back to the most efficient dimensions to display the spread.

Optimize Palette Size for Spread
To automatically change the width of the palette as you move between
spreads of one page or more than one page (again, to save screen real
estate), check Optimize Palette Size for Spread. The proportions of
page representations in the preview remain the same.
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Color 
To change the background color of the palette (the margin around the
preview), click the Background swatch and use the controls in the Apple
Color Picker to pick a new color.

To change the color of the spine between pages in a preview spread,
click the Spine swatch and use the controls in the Apple Color Picker to
pick a new color.

To change the color of the preview page edges , click the Page Edge
swatch and use the controls in the Apple Color Picker to pick a new color.

To specify the color of the progress bar that indicates the status of the
palette display update, choose one of the Progress Bar options.

Come. Home, and Close buttons
The Come button lets you define a key combination that will display the
palette at the current pointer location, or move the palette to that location
if the palette is currently displayed. To specify the key(s), hold down the
key(s) and click Come.

To specify the key(s) that will move the palette to the “home” position
specified by choosing Save Palette Position from the pop-up menu in
the palette, hold down the key(s) and click Home.

To specify the key(s) that will close the palette, hold down the key(s)
and click Close. You must click on the palette while holding the Close
combination.
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You can use any combination of the Command, Option, Control, and
Shift keys when specifying key combinations for the Come/Home/Close
feature.

Note: The Come/Home/Close feature is also available for the XPert Com-
mands XTension (included in this volume). Be careful not to specify the
same key combinations for both XTensions, lest they conflict and cause
unexpected results.

Reset
To return the settings in the dialog box to their defaults, check Reset.
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What is XPert CommandPad?
The XPert CommandPad XTension lets you create your own custom
palettes that allow you to access any QuarkXPress function with a click
of the mouse. The XPert CommandPad palettes you create (hereafter
referred to as “CommandPads”) can contain tools, any menu command
available in QuarkXPress, and most keyboard combinations (such as
increasing and decreasing font size). You can create as many Command-
Pads as you like, tailoring each for certain tasks.

This illustration shows a custom CommandPad that allows access a variety of typogra-
phy-related features ranging from horizontal/vertical scaling to text flipping.

What XPert CommandPad adds to QuarkXPress
XPert CommandPad adds two commands to the QuarkXPress menus:
Edit > XPert CommandPad and View > XPert CommandPad.

• Edit > XPert CommandPad allows you to create, name, and save custom
CommandPads.

• View > XPert CommandPad lets you show and hide your Command-
Pads. The illustration above shows four user-defined CommandPads
in the submenu.
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Creating and Working with CommandPads
Choose Edit > XPert CommandPad to display a dialog box that lets you create
and edit CommandPads. This dialog box looks and behaves a lot like Quark
XPress’ Style Sheets dialog box.

CommandPad scroll list
This scroll list displays all CommandPads that have been created. To
work with a set, select it and click one of the buttons or double-click the
set to display the Edit CommandPad Style dialog box.

New
To create a new CommandPad set, click New. Clicking New displays
the Edit CommandPad Style dialog box. Using the Edit CommandPad
Style dialog box is discussed on page 70. You can create as many Com-
mandPads as you want.

Edit
To edit an existing CommandPad set, select the set in the scroll list and
click Edit (or double-click). Clicking Edit displays the Edit Command-
Pad Style dialog box. Using the Edit CommandPad Style dialog box is
discussed on page 70.
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Duplicate
To create a copy of an existing CommandPad set, select the set in the
scroll list and click Duplicate. Clicking Duplicate displays the Edit
CommandPad Style dialog box. Using the Edit CommandPad Style
dialog box to edit sets is discussed on page 70.

Delete
To remove an existing CommandPad, select the set in the scroll list and
click Delete. Shift-click and Command-click to select more than one
CommandPad.

Display Command Label
To display a small label for CommandPad buttons when you place the
mouse pointer over a button, check Display Command Label.

Who can remember the names of all these little buttons? If you forget, XPert CommandPad
will give you a gentle reminder.

When the check box is selected, you can specify the interval before the
label displays by entering a value between 1 and 120 in the Delay field. A
low value make the display almost instantaneous; higher values delay the
display by a few seconds.

To specify the color of the labels, click the Color swatch and choose a color
from the standard color-picker dialog box displayed.

Note: To quickly turn the labels on and off while working with a particular
CommandPad, hold down the Option key and click on the CommandPad
title bar.
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Editing CommandPads
Clicking New, Edit, or Duplicate in the CommandPads dialog box dis-
plays the Edit CommandPad Style dialog box. You can also display this
dialog box by double-clicking a CommandPad name.

You can create CommandPads with certain tasks in mind. For example,
if at some stage in your document creation process you work extensively
with pictures, you could create a “Picture commands” CommandPad
that contained exclusively picture-related features. Likewise you could
do the same for typographic features, layout features, and so on.

Name
Specify a name for the newly created or edited set. The name you assign
will be displayed in the CommandPads dialog box scroll list.

Tool Pad
The Tool Pad area display controls that let you specify the look of the
custom CommandPads you create.
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To specify whether the title bar of the CommandPad is placed on the top
or left side, click one of the two icons on the left side of the area.

Button Size
To specify the size of the buttons in your CommandPad, enter a value in
the Button Size field from 20 to 32 (pixels).

Button Gap
To specify the distance between the buttons in your CommandPad,
enter a value in the Button Gap field from 0 to 6 (pixels).

Divider Gap
You can separate groups of buttons in your CommandPad with
dividers. To specify the width of the dividers in your CommandPad,
enter a value in the Divider Gap field from 0 to 12 (pixels).

Display Title
To display the name you enter in the Name field in the title bar of your
CommandPad, check Display Title.

Use Click Sound
To hear a distinct clicking sound when you click one of the buttons in
your CommandPad, check Use Click Sound.

Specifying Palette Color
To specify the color of the buttons in your CommandPad, click on one of
the sample buttons. Use the standard Apple color picker to select a
color.

To specify the background color of your CommandPad, click on the
sample background. Use the standard Apple color picker to select a
color.

To set the buttons and background to the default colors you have set up
for your Mac, hold down the Option key and click on a sample button.
To return the colors to the original gray default, hold down the Com-
mand key and click on a sample button.
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Commands
The Commands area displays two scroll lists that let you add, remove,
and arrange the buttons in your CommandPad. The Category pop-up
menu lets you control which commands, tools, XTensions, etc. are dis-
played in the left-hand scroll list.

There is no limit (other than common sense) to the number of buttons
you can add to a CommandPad.

Category
To control which commands are displayed in the left-
hand scroll list, choose a category from the Category
pop-up menu. Choose All to display every available
command, tool, and XTension.

Note: Currently, you can access only ALAP XTensions via
CommandPads. In the future, other XTension developers
will be able to list their XTensions here as well.

To display additional, non-QuarkXPress options, choose
Other. Other lets you add CommandPad buttons for
accessing Apple menu items and launching third-party
applications.

The triangle to the left of Category lets you display all of the subcate-
gories available under categories that contain additional options. For
example, to display each of the various kinds of Preferences, you would
click this triangle.

Note: When you add a category that contains subcategories (such as the Font,
Size, or Type Style submenus), clicking the button in the CommandPad
displays a pop-up menu with the entries in that category.

To add a command to the CommandPad, select it in the left-hand scroll
list and click Add (or double-click on the command). Shift-click and
Command-click to select more than one command.
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To remove a command from the CommandPad, select it in the right-
hand scroll list and click Remove (or double-click on the command).
Shift-click and Command-click to select more than one command.

To drag selected commands between the scroll lists, hold down the
Option key and drag when the closed hand pointer displays. When you
are dragging a command into a CommandPad, you can control where in
the scroll list the button will be placed by releasing the mouse button
when the arrows are displayed in the desired location.

To add a divider to a CommandPad to separate groups of buttons, click
Divider. To remove a divider, select it in the right-hand scroll list and
click Remove (or double-click on the divider).

To rearrange the buttons, click on a command in the right-hand scroll
list, hold down the Option key, and drag the command up or down and
release the mouse button when the arrows are displayed in the desired
location. You can also drag dividers up and down in the scroll list.

Working with XPert CommandPads
To display the CommandPads you have created via Edit >XPert Command
Pad, choose View > XPert CommandPad and select a CommandPad
from the submenu. To hide a CommandPad that is currently displayed,
choose Hide [Name] from the submenu.

This illustration shows four user-defined
CommandPads available in the submenu.
Notice that each has been named according
to the type of functions it performs. Two are
currently displayed, two are hidden.
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This is a small CommandPad that contains just five commands: Select All, Undo,
Find/Change, Style Sheets, and Save Page as EPS.

You can move, close, and resize your CommandPads, as you can other
QuarkXPress palettes. To resize a CommandPad, move the pointer over
the lower right corner and drag when the pointing finger displays. To
increase the size of the “hot spot,” and therefore make hitting it with the
mouse pointer a little easier, hold down the Option key before clicking
on the lower right corner.

This illustration shows a CommandPad being
resized. CommandPads can be horizontal, 
vertical, or display tools in a grid pattern.

Changing Palettes on the fly
You can change the order of buttons in a CommandPad and drag but-
tons between open CommandPads. While you are dragging a button,
the new location is indicated by two small arrows.

To reorder the buttons in a CommandPad, hold down the Control key
and drag a button when the grabbing hand pointer displays. Release
the mouse when the arrows indicate the desired location for the button.

To copy a button from one currently displayed CommandPad to
another, hold down the Control key and drag a button over the desired
CommandPad when the grabbing hand pointer displays. Release the
mouse when the arrows indicate the desired location for the button.

To cut a button from one currently displayed CommandPad and paste it
into another, hold down the Control and Shift keys and drag a button
when the grabbing hand pointer displays. Release the mouse when
the arrows indicate the desired location for the button.

Note: You can copy/move buttons between CommandPads with differ-
ent button sizes. The copied/moved button will take on the size appro-
priate for the new CommandPadCommandPad.

To quickly edit a CommandPad, hold down the Command key and click
on the title bar to display the Edit CommandPad Style dialog box.
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Tips
• XPert CommandPad palettes support System 7 balloon help. Should

you desire more information about the task a button performs than is
provided by its label, choose Show Balloons from the Help menu in
the upper right corner of your screen. Place the pointer over the but-
ton in the palette to display the balloon.
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XPE R T SC R I P T E R

What is XPert Scripter?
The XPert Scripter XTension provides a way to launch OSA-compliant
AppleScript scripts from within QuarkXPress. An AppleScript script
is a document that behaves like a miniature computer program. When
launched, a script can get information from certain applications like
QuarkXPress (that have been specially programmed to work with
AppleScript) and can send commands to these applications, as well. 

You can develop or purchase simple scripts that automate repetitive
tasks in QuarkXPress. More sophisticated scripts can be developed
that perform tasks like importing data and automatically building
QuarkXPress pages based on that data.

The XPert Scripter XTension lets you import AppleScripts into a float-
ing palette, called the Script Player palette, from which you can
launch scripts by double-clicking on them. XPert Scripter also lets you
group scripts in sets that, when activated, will run all the scripts in
the set, one after the other. Entire work flows can be created with
script sets, so that a task that would normally require many steps to
accomplish can be performed by a single script set. 

This illustration shows the Script Player palette with several scripts and one set.

XPert Scripter also provides an easy method for naming QuarkXPress
items (i.e., text boxes, picture boxes, lines) so that they can be easily
located and modified by AppleScripts. 
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What XPert Scripter adds to QuarkXPress
XPert Scripter adds three commands to the QuarkXPress menus: Edit > Preferences
> XPert Scripter, View > Show Script Player, and View > Show Item Names.

• Edit > Preferences > XPert Scripter displays a dialog box that lets you control the
way information is displayed in name fields when Show Item Names is selected.

• View > Show Script Player displays the Script Player palette, which lets you
choose, load, and launch AppleScripts. The palette also lets you create script sets
and to run a series of scripts by launching a script set.

• View > Show Item Names displays non-printing fields over items that indicate
the stacking order of items in a spread and the items’ names, if names have been
assigned.
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Learning More About AppleScript
This manual assumes that you are familiar with AppleScript, its termi-
nology and usage. If you are new to scripting or would just like more
information on the subject, ALAP recommends purchasing Danny
Goodman’s book, The Complete AppleScript Handbook, published by 
Random House (ISBN 0-679-79148-5). It is a thorough reference work
and can provide answers to many of your scripting questions.

The scripts shown in the screen captures for this manual are from a col-
lection called Sal’s AppleScript Snippets. This collection of more than 65
scripts written for QuarkXPress not only provides tools for automating
many production tasks, but also demonstrates many of the commands
and syntax necessary to perform scripting tasks in QuarkXPress. The
scripts are fully editable, and can be opened and viewed as examples of
how to script QuarkXPress. The Snippets are available from the same
dealer you purchased XPert Tools from, or call Nyhthawk Productions
at (804) 979-9086 USA. Some scripts from this collection have been
included in this package.

Displaying the Script Player palette
Choosing View > Show Script Player displays the Script Player palette,
which lets you choose, load, and launch AppleScripts. The Script Player
palette also lets you create script sets and to run a series of scripts by
launching a single script set. When the Script Player palette is displayed,
choosing View > Hide Script Player closes the Script Player palette. You
can move and resize the palette like most QuarkXPress palettes.

Working with the Script Player palette
The Script Player palette contains two list areas, separated by a movable
divider. The upper list, the Script list, displays the names of the scripts
that have been loaded already; the bottom scroll list, the Set list, displays
the script sets that have been created using the Script Player palette. 
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The Script Player palette displays two list areas, shown here
before any scripts have been loaded or sets created.

To adjust the display size of the two lists, place the cursor over the
double-line divider and drag the mouse vertically when the cursor
changes to a double line with arrows.

Using the Script Player’s Control Buttons
The topmost area of the palette contains the four Script Player control
buttons.

To load existing AppleScripts into the Script Player palette, click .
Scripts that have been loaded are displayed in the Script list (top list) of
the palette.

To create script sets, click . Script sets are displayed in the Script Set
list (bottom list) of the palette.
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To apply custom “labels” to scripts and to view lists of scripts according
to label, click .

To remove a script or Script Set from a palette list, select the scripts or
sets you want to remove and click .

Loading Scripts
To select existing AppleScript files for loading into the Script Player
palette, click in the palette’s control button area. The Please Select a
Script dialog box is displayed. Use the controls in the dialog box to
locate and select the scripts you want to load. 

To load a single script, select the script from the dialog box scroll list and
click Add. To load every script in the selected folder, click Add All. When
you load a script, the Script Player palette only maintains a reference to a
script’s file on disk; the palette does not load script file’s contents. Once
loaded, the scripts’ names are added to the Script list. 
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Launching Scripts
To launch a script, double-click on the script’s name in the Script Player
palette’s Script list. This will launch and run the script. 

Keep in mind that many scripts require that certain conditions be met
before they will work. For example, a script may require that there be a
certain kind of box selected (such as a text or picture box) or that a range
of text be selected, for the script to execute correctly. Well written scripts
place safeguards and warnings to alert the user if required conditions
don’t exist in the QuarkXPress document. XPert Scripter cannot make
poorly written scripts work correctly.

Viewing Script Information
To view information about a script, hold down the Control key and
double-click on a script name. The “Script Information” dialog box is
displayed. 

This dialog box displays information written into the script when it was
created. If no information was placed into the script, none will display in
the Script Information dialog box. 

The Script Information dialog box displays four additional information
fields. The Where field displays the location of the script on your
drive/network. The Created, Modified, Version fields will only display
if the appropriate version information is stored in the script.

Note to Scripters: If you want the Script Player palette to be able to dis-
play information about your script, include a ‘vers’ resource of id 1 in
the script file.
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What are Script Sets?
You can combine multiple scripts into groups and save these groups as
script sets. The scripts in a script set will run one after another, until the
last script in the set has completed. Using a script set allows you to com-
bine smaller scripts to perform more complex tasks or work flows. 

For example, you may have these individual scripts:

1) a script that creates a picture box, imports a picture into that box,
and adjusts the picture box to the size of the image.

2) a script that scales both the picture and its box.

3) a script that accesses the file name of the picture inside the picture
box and creates a text box beneath the picture box and places the pic-
ture name inside it.

4) a script that places crop marks around the picture box.

By placing these four scripts into a script set, and launching the set, they
will run as if they were one continuous script. (These script’s are exam-
ples of some scripts contained in Sal’s AppleScript Snippets collection men-
tioned in the Learning More About AppleScript section of this chapter.)

Creating Script Sets
To create a script set, click in the palette’s control button area. The
Create Script Set dialog box is displayed.
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To name the new script set, enter a name in the field and click OK. The
new script set is added to the Script Set list at the bottom of the Script
Player palette.

Adding Scripts to Script Sets
There are two ways to add scripts into a script set: by dragging scripts
from the Script list onto a script set in the Script Set list, or by using the
Edit Script Set dialog box (as described in Editing a Script Set, below). 

To drag scripts into a script set, select the scripts you want to include
from the Script list and hold down the Option key. The cursor will
change to a hand cursor. Move the cursor over one of the selected script
names and click and hold the mouse; the hand cursor will close. Drag
the closed hand cursor over the Script Set list and select a script set
from the list. The selected script set will be highlighted as the cursor
moves over it. Release the mouse button to add the scripts to the
selected script set.

Scripts can be added to as many script sets as needed. And, you can use
a script more than once in the same script set.

Editing a Script Set
To add scripts to a script set, reorder the scripts in a set, or to delete a
script from a set, hold down the Option key and double-click on a script
set. The Edit Script Set dialog box is displayed.
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The Scripts in Set scroll list, on the left of the dialog box, displays the
scripts contained in the selected script set. The Scripts scroll list, on the
right, displays the scripts currently loaded in the Script Player palette.

Adding Scripts to a Script Set 
To add a script or multiple scripts into the script set, select their names
from Scripts scroll list and click Add. You can also hold down the
Option key and drag scripts from the Scripts scroll list to the Scripts in
Set scroll list.

Reordering the Scripts in a script Set
To reorder the scripts in a script set, hold down the Option key and
select a script in the Scripts in Set scroll list. Drag the selected script to a
new position in the list. The number to the left of the script name indi-
cates its order in the set. When you launch a script set, its scripts will run
one after another, in the order they are displayed in the Scripts in Set
scroll list.
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Removing Scripts from a Script Set
To remove a script from a script set, select the script and click Delete.

Labeling Scripts
As the number of scripts loaded into the Script Player increases, you
may find it useful to group scripts by label. Labeled scripts can be hidden
and sorted so that it is possible to display only the scripts you need for
the current task.

Creating Script Labels
To create a label, click in the palette’s control button area to display
the Labels pop-up menu. Choose Edit Labels from the pop-up menu to
display the Label dialog box.

Click New in the Labels dialog box to display the Create New Label
dialog box.
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To create the label, enter a name in the field. Click Color to assign a
color to the new label (the default color is black), or click OK to create
the label.

If you click Color in the Create New Label dialog box, the standard
Apple Color Picker is displayed. To apply color to a label, choose the
color you want from the color picker and click OK. Darker colors seem
to work best, especially reds and blues. 

Removing Script Labels
To remove a label, click in the palette’s control button area to display
the Labels pop-up menu. Choose Edit Labels from the pop-up menu to
display the Label dialog box.

To remove a label, select the label you want to delete from the scroll list
and click Remove.
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Sorting Scripts by Label
To display script names in the Script Player palette sorted alphabetically
by label, check Sort By Labels.

Applying Labels to Scripts
To choose the scripts you want to label, select the scripts from the Script
list in the Script Player palette. Hold down the Shift key when clicking
on script names to select multiple scripts. Make non-contiguous selec-
tions by holding down the Command key while selecting scripts. Click
anywhere on the list while holding down the Option and Command
keys to select all the scripts in the list.

To apply a label to selected scripts, hold down the Command key when
you click . When you apply a label to a script, the script may not be
displayed in the palette’s list of script names if labels with that script are
currently set not to display. See Viewing Scripts by Label, which follows
immediately, for more information.
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Viewing Scripts by Label
Once labels have been created and applied to scripts, you can limit the
contents of the Script list in the Script Player palette to only those scripts
with the label you choose, or with no label, or regardless of label.

To view scripts by label, hold down the command key and click in
the palette’s control button area to display the Labels pop-up menu.
Choose the label you want to apply to the selected scripts from the 
pop-up menu. 

To display all scripts loaded into the Script Player palette, choose Show
All Labeled from the Label pop-up menu. To display only unlabeled
scripts, choose Hide All Labeled from the Label pop-up menu.

If you selected a color for a label when you created it, the scripts to
which it is applied are displayed in that color in the Script list.
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Removing Applied Labels from Scripts
To remove a label from scripts, select the scripts from the Script list, hold
down the Command key and click in the palette’s control button area
to display the Labels pop-up menu. Choose Remove Label from the
pop-up menu. 

Deleting Scripts from the Script Player palette
To delete scripts from the Script Player palette, select the scripts you
want to remove and click in the palette’s control button area. The
script names will be removed from the palette’s list but the actual
AppleScript files are not deleted on disk.

Activating a Single-Play Script
You can use the Script Player palette to launch a script without loading
it into the palette. To do this, hold down the Option key and click in
the palette’s control button area. The Please Select a Script dialog box is
displayed. Use the dialog box controls to locate the script, then click
Open. The script will run one time, but will not be added to the Script
Player’s script list.

 

A Note to Script Writers: Error Checking for Scripts
Scripts written for QuarkXPress for general use by others should incor-
porate error-checking routines to alert the user to problems encountered
by the script. XPert Scripter cannot provide error-checking for scripts —
it only launches them.
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Error checking should be written into each script. Below are some com-
mon things to check for:

• If a document is needed, check to see if a document is open.

• If necessary, check to see that the proper items are selected.

• Check to be sure related files are in their expected locations.

• Check that the proper page or spread is displayed or available.

It’s best not to assume that the user knows anything about how the
script should function. Expect the unexpected!

ALAP also recommends you provide help notes and instructions when
writing the script by placing comments in the Description area in the
AppleScript Script Editor window. These notes will be accessible to the
user by holding down the Control key and double-clicking the script
name in the Script Player palette. Good luck and happy scripting.

Naming Boxes
QuarkXPress AppleScript developers frequently use item names as a way
of providing access to a specific items within a QuarkXPress document.
The NameIt feature lets users name QuarkXPress items so that scripts
can locate items by name. The NameIt feature makes it easier for scripters
to developed their scripts. QuarkXPress users can use this features to
look for specific boxes by name, which can save time scrolling through
document pages looking for the correct box.

Displaying NameIt fields
To view box names, choose View > Show Item Names. NameIt fields
are displayed over items in the QuarkXPress document. These non-
printing fields indicate the stacking order of items in a spread and the
items’ names, if names have been assigned. Choose View > Hide Item
Names to hide NameIt fields.

The numbers in the NameIt fields provide a visual method for viewing
the order in which QuarkXPress items are layered on a page or spread.
Items are stacked from 1 (the bottom layer) to the last number displayed
in a NameIt field (the top layer).
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Assigning and Editing Item Names
To assign a name to an item or to edit an existing name, hold down the
Command key and click the icon at the left of the NameIt field. When
the NameIt field becomes active, enter the name you want to apply to
the item and press Return. Once an item is named, scripts can locate and
access the item by name. To cancel out of a NameIt field without entering
a name, press the esc (escape) key.

Editing NameIt Preferences
To specify the way in which NameIt fields display information, choose
Edit > Preferences > XPert Scripter. The XPert Scripter Preferences dia-
log box is displayed.

Display Reference
To specify the information displayed in NameIt fields, check Names
and/or Numbers in the Display Reference area.

The Max Display field determines (in pixels) how wide the maximum
size of a NameIt field can be. To change the displayable width of a
NameIt field, enter a value from 45 to 640.

Show Names For
To enable NameIt field display for the various item types, check Picture
Boxes, Text Boxes, and/or Lines in the Show Names For area. NameIt
fields will display on checked item types when you select View > Show
Item Names.
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What is XPert Rulers?
The XPert Rulers XTensions provides two features that make working
with page elements easier. 1) You can display floating rulers that snap to
the items on a page, allowing you to quickly create guides and align
items. 2) The Measure Tool finds the distance and angle between any
two points.

What XPert Rulers adds to QuarkXPress
XPert Rulers adds two commands to the QuarkXPress menus: Edit >
Preferences > XPert Rulers and View > Show/Hide XPert Rulers. The
XTension also adds a new tool to the tool palette.

• The Measure tool added to the QuarkXPress tool palette lets you mea-
sure the distance and angle between any two points in a document.

• Choosing Edit > Preferences > XPert Rulers displays a dialog box that
you can use to tailor XPert Ruler’s functions.

• Choosing View > Show XPert Rulers displays floating rulers that you
can move and attach to items.
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Working with Rulers
Choose View > Show XPert Rulers to display the rulers. When the rulers
are showing, the menu entry changes to Hide XPert Rulers. If Quark
XPress’s rulers are currently displayed, the floating rulers will initially
display next to them (unless the default preference is to have rulers snap
to items).

Note: These techniques work only when Snap to Item in the XPert
Rulers dialog box is unchecked.

When Snap to Item is unchecked, you can force the rulers to snap back
to the edge of the current document window by holding down the
Option-Command-Shift keys and clicking on either ruler.

Moving Rulers
To drag a ruler to a new location on-screen, move the pointer over the
ruler and click anywhere on the ruler when the Grabber Hand Pointer
displays.

To drag both rulers to a new location on-screen, move the pointer over
the ruler, hold down the Shift key, and click anywhere on the ruler
when the Grabber Hand Pointer displays.

Resizing Rulers
To resize a ruler, move the pointer over an end of the ruler and click and
drag when the Resizing pointer displays.
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Working With Ruler Guides

Creating Ruler Guides
To create a ruler guide, hold down the Control key and click anywhere
on a ruler when one of the Guide Creation pointers displays. To place
the ruler guide, release the mouse button when the pointer is over the
document. Click on the horizontal ruler to create vertical guides, and the
vertical ruler to create horizontal guides.

To create a ruler guide that extends across one page, release the mouse
button when the pointer is over that page. To create a ruler guide that
extends across the pasteboard and all pages on the spread, release the
mouse button when the pointer is over the pasteboard. 

Note: Choose View > Show Guides before working with ruler guides.

Deleting Ruler Guides
To delete ruler guides, hold down the Option key and click on a ruler
when the Arrow pointer displays. Click on the horizontal ruler to delete
vertical guides, and the vertical ruler to delete horizontal guides.

To delete all guides on a page, hold down the Option key and click on a
part of the ruler that is over the page. To delete guides that extend across
all pages and the pasteboard, hold down the Option key and click on a
part of the ruler that is over the pasteboard.

To delete all guides (horizontal and vertical) on the current page or
spread, hold down the Option and Shift keys and click on either ruler.
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The Measure Tool
To measure the distance between any two points in a document, click on
the Measure Tool in the QuarkXPress tool palette. You can also use the
keyboard equivalent Control-M to toggle Measure tool mode on and off.

A B C

A) Select the Measure tool.

B) Move the crosshair pointer to the first desired endpoint of the measurement.

C) Click and drag the crosshairs to the second desired endpoint of the measurement.

The display will indicate the horizontal Width, vertical Height, total 
Distance, and Angle between the two endpoints.

�When you release the mouse button, the measurements disappear and
the previous tool is automatically selected.
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Setting XPert Rulers Preferences
Choosing Edit > Preferences > XPert Rulers displays a dialog box that
lets you control the look and the behavior of XPert Rulers. (You can also
display the XPert Rulers dialog box by double-clicking on either floating
rulers or on the Measure Tool.)

Rulers
To control the way floating rulers behave in your documents, use the
controls in the Rulers area.

Snap to Item
Check Snap to Item for rulers that move automatically to selected boxes,
lines or groups. If no items are selected, or if the selected item is not visi-
ble, rulers snap to the edge of the document window.

When Snap to Item is checked, you cannot move or resize the rulers.

When Snap to Item is unchecked, you must position rulers manually.

Use Document Origin
The origin of a document is the zero point of the QuarkXPress rulers.
The zero point of floating rulers can be set to always equal the Quark
XPress ruler origin, or can be set to always start at the edge of the floating
rulers, wherever they are positioned.

Check Use Document Origin for ruler measurements relative to the origin
of the current document. Uncheck this box for measurements relative to
the ruler’s edge.

Display Bottom Right
To snap rulers to the bottom and right side of the active item (as
opposed to the top and left sides), check Display Bottom Right. When
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this option is checked, and Snap to Item is unchecked, rulers snap to the
bottom and right side of the document window. Tick marks display on
the top and left of the rulers.

Color
To change the background color of the rulers, click the Ruler swatch and
use the controls in the standard color picker dialog box to pick a new color.

To change the color of the tick marks and numerals used in the rulers,
click the Tick swatch and use the controls in the standard color picker
dialog box to pick a new color.

Note: To set the color to the default colors you have set up for your Mac,
hold down the Option key and click on either Color swatch.

Command-click on either Color swatch to set the color to the XPert
Rulers default colors (i.e. black & white).

Show Crosshairs
Check this box to display crosshairs that extend the width and height of
the screen when using the Measure Tool or creating a box.

Dimensions
To control the display of dimension information in your documents, use
the controls in the Dimensions area. The settings you specify in this area
apply the Measure Tool and the ruler guides you create from floating rulers.

Display with Guides
To see coordinates while creating or moving ruler guides from floating
rulers, check Display with Guides.
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Font and Size
Choose the font for both the Measure tool and ruler guide coordinates,
from a list of fonts available in the current System.

Choose the size for both the Measure tool and ruler guide coordinates.

Measure
To specify the measurement units for the floating rulers and the Measure
tool, choose an option from the Measure pop-up menu. Choose Docu-
ment Setting to use the measurement units of the current document.
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What is XPert PageSets?
The XPert PageSets XTension lets you save and apply document setup
information (size, columns, margins, and so on) in a manner similar to
colors and style sheets. These settings are saved as pagesets. You can
apply all of the specifications in a pageset to a document when you first
create a document. When a document is open, you can apply document
set up specifications from the Document Setup dialog box (File menu)
and margin guide specifications from the Margin Guide dialog box
(Page menu).

What XPert PageSets adds to QuarkXPress
XPert PageSets adds a pop-up menu to the New Document, Document
Setup and Master Guides dialog boxes that let you create and apply
pagesets.

The New Document dialog box contains a pagesets pop-up menu when the PageSets
XTension is installed. This illustration shows the pop-up menu after three pagesets have
been created.

Creating PageSets from the New Document dialog box
Choose File > New > Document to display the New Document dialog
box.

Use the dialog box controls to specify the values and settings you want
to include in the pageset.
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From the pop-up menu added at the top of the dialog box, choose Add.
A dialog box for naming pagesets displays. Enter a name and click OK.

The new page set is added to the pop-up menu.

Creating PageSets from the Document Setup dialog box
To create a pageset based on the size of an open document, choose File >
Document Setup.

Use the dialog box controls to specify the dimensions you want included
in the pageset.

From the pop-up menu added at the top of the dialog box, choose Add.
A dialog box for naming pagesets displays. Enter a name and click OK.

Remember that pagesets contain both document size and margin guides
information. Therefore, pagesets created from this dialog box will by
default use the master page settings from the Master Guides dialog box
for Master Page A of the active document.
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Creating PageSets from the Master Guides dialog box
To create a pageset based on the guides of an open document, display a
master page and choose Page > Master Guides.

Use the dialog box controls to specify the guide settings you want
included in the pageset.

From the pop-up menu added at the top of the dialog box, choose Add.
A dialog box for naming pagesets displays. Enter a name and click OK.

Remember that pagesets contain both document size and margin guides
information. Therefore, pagesets created from this dialog box will by
default use the current document dimension settings from the Docu-
ment Setup dialog box.

Applying Pagesets
All pagesets you create contain both page size and guide information.
All of this information is applied only when you apply pagesets via the
New Document dialog box.

To apply both the size and guides information from a pageset to a new
document, choose File > New > Document to display the New Docu-
ment dialog box. Choose a pageset from the pop-up menu in the upper-
right corner. Each of the controls will reflect the settings of the pageset.
Click OK.

To apply just the document size from an existing pageset to an open
document, choose File > Document Setup. Choose a pageset from the
pop-up menu in the lower-right corner. Each of the controls will reflect
the settings of the pageset. Click OK. (Note that the placement of the
margin and column guides in the document will not be affected.)
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To apply just the margin guides from an existing pageset to an open
document, display a master page and choose Page > Master Guides.
Choose a pageset from the bottom of the pop-up menu in the upper-
right corner. Each of the controls will reflect the settings of the pageset.
Click OK. (Note that the size of the document will not be affected.)

Deleting Pagesets
To delete a pageset, hold down the Command or Shift keys, open the
pop-up menu in any of the three dialog boxes, and choose the Pageset to
be removed.

Note: When you hold down the Command or Shift keys before display-
ing the pop-up menu, the first entry in the menu will be the gray word
Remove.
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What is the XPert ItemMarks XTension
The XPert ItemMarks XTension lets you quickly create custom crop
marks and registration targets around QuarkXPress items. This is an
especially useful feature for those who need special crop marks and for
those who prepare color work, as QuarkXPress alone print marks only
around spreads. XPert ItemMarks lets you specify the size, line weight,
and offset for the targets and marks you create. XPert ItemMarks also
lets you place color and grayscale proofing swatches. The targets, marks,
and swatches created by XPert ItemMarks are QuarkXPress items that
you can modify.

The illustration shows the five types of marks you can create with XPert ItemMarks. In
this example, two QuarkXPress items (the boxes) were active when the marks were placed
using XPert ItemMarks.
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What XPert ItemMarks adds to QuarkXPress
XPert ItemMarks adds two commands to the QuarkXPress menus:

• Edit > Preferences > XPert ItemMarks displays the XPert ItemMarks
Preferences dialog box. Use the controls in this dialog box to define
the marks you place.

• Item > Create XPert ItemMarks places a set of marks around active
QuarkXPress items. The types of marks created with this command
are determined by the settings in the XPert ItemMarks Preferences
dialog box.

Defining XPert ItemMarks Marks
Choose Edit > Preferences > XPert Item Marks to display the XPert
ItemMarks Preferences dialog box. The controls in this dialog box let
you specify the size, line weight, and offset for the targets and marks
created when you choose Item > Create XPert ItemMarks. 

You can also display this dialog box by holding down the Option key
when choosing Item > Create XPert ItemMarks.
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The check boxes on the left side of the XPert ItemMarks Preferences dialog box let you
specify which types of marks you want XPert ItemMarks to create; the fields on the right
let you specify their weight, length, size, and offset.

Crop Marks, Targets, CMYK Plate Names, Color Bars, Gray Bars
To select the kinds of marks that XPert ItemMarks creates when you
choose Item > Create XPert ItemMarks, select from the check boxes on
the left side of the dialog box. The options are Crop Marks, Targets,
CMYK Plate Names, Color Bars, and Gray Bars. Checked items are
placed when you choose Create XPert ItemMarks. 

Line Weight
To specify the thickness of the lines used for crop marks (trim lines) and
targets, enter a value in the Line Weight field. 

Line Length
To specify the length of the lines used for crop marks, enter a value in
the Line Length field. 

Mark Size
To specify the dimensions of targets and the boxes used to create color
and grayscale swatches, enter a value in the Mark Size field. The value
you enter determines the size of each element. For example, if you specify
12 points, each of the four colored boxes that make up the CMYK Tag
will be 12 points square — for a total of 48 points in length.

Mark Offset
To specify the gap between selected items and the marks you specify,
enter a value in the Mark Offset field.
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Placing XPert ItemMarks marks
To place the targets, crop marks, and bars specified in the XPert ItemMarks
Preferences dialog box, select an item or items that you want to print
and choose Item > Create XPert ItemMarks. The marks created by XPert
ItemMarks are editable QuarkXPress items. These items are initially
placed as a single group but they are easily ungrouped and altered
using standard QuarkXPress tools.

Tips
• Use XPert ItemMarks in conjunction with the XPert Print XTension

(available from a lowly apprentice production in XPert Tools Volume 1)
to print a small area of a large QuarkXPress page with registration marks.
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What is XPert BoxTools?
The XPert BoxTools XTension adds several commands to the Quark
XPress Style and Item menus for working with text and picture boxes
and their contents. The BoxTools commands lets you:

• Resize a picture to fit a box.

• Resize a box to fit a picture.

• Change a text box to a picture box (and vice versa).

• Set text insets for individual text box edges.

• Horizontally and vertically align an item on a page.

What XPert BoxTools adds to QuarkXPress

XPert BoxTools adds two commands to the Style menu when a picture
box is active: Style > Fit Picture to Box and Style > Picture Scale.

Two commands are added to the Item menu when a picture box is
active: Item > Change Picture Box to Text Box and Item > Size Box to
Picture.

Two commands are added to the Item menu when a text box is active:
Item > Change Text Box to Picture Box and Item > Text Box Insets.

One command is added to the Item menu when a picture box, text box,
or group is active: Item > Align Item to Page.
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Using the XPert BoxTools commands
XPert BoxTools adds commands to both the Style and Item menus.

Picture-Related Commands added to the Style menu
To fit a picture to its picture box so that the picture retains its original
proportions, choose Style > Fit Picture to Box when a picture box is
active. To resize a picture so that it fills the entire picture box without
regard to the picture’s proportions, hold down the Option key before
choosing Style > Fit Picture to Box.

To proportionately resize a picture by a specific value, choose Style >
Picture Scale. In the Picture Scale dialog box, enter a reduction or
enlargement value as a percentage. You can enter values in .1-percent
increments. 

Commands added to the Item menu
The XPert BoxTools commands available in the the Item menu are active
or disabled, depending on whether a picture box, text box, or group is
active. (See the Item menu illustrations on the previous page.)

Commands available when a picture box is active
To change a picture box to a text box, select the picture box you want to
change and choose Item > Change Picture Box to Text Box. An alert dis-
plays to remind you that any content in the picture box will be deleted if
you click OK.

To resize a picture box so that it is the same size as the picture’s bounding
box area, choose Item > Size Box to Picture. Remember, the imported
picture’s bounding box might be larger than the picture’s image area,
resulting in additional white space around the image.

Commands available when a text box is active
To change a text box to a picture box, select the text box you want to
change and choose Item > Change Text Box to Picture Box. An alert
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displays to remind you that any content in the text box will be deleted if
you click OK.

To modify one or all of the text inset values for a text box, choose Item >
Text Box Insets. The Text Box Inset dialog box is displayed.

You can specify individual insets for the Top, Bottom, Left, and Right
edges of the text box. The inset values you enter specify the minimum
distance from the four box edges to text within a box. 

Commands available when a picture box, text box, or group is active
To align an item horizontally and/or vertically at the top, bottom, left
edge, right edge, or center of a page, select the item and choose Item >
Align Item to Page. The Align Item to Page dialog box is displayed.

To change the selected item’s horizontal position, check Horizontal.
Click Left, Center, or Right for the horizontal alignment of the item.

To change the selected item’s vertical position, check Vertical. Click
Top, Center, or Bottom for the vertical alignment of the item.

Align Item to Page is not available when multiple items are selected.
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What is XPert JobLog?
The XPert JobLog XTension keeps track of many kinds of changes that
were made to documents, and who made them. The XTension also lets
you name a document at the time you create it and save a report of the
document history.

What XPert JobLog adds to QuarkXPress
XPert JobLog adds one command to the QuarkXPress menus: 
Utilities >  XPert JobLog.

• Choosing Utilities > XPert JobLog displays a dialog box that lists the
actions applied to the active document.

Using XPert JobLog
When you create a new document, XPert JobLog displays the Create
Document Log dialog box, which lets you specify both a user name and
a document name. Enter the information and click OK to display the
new document with the specified name in the title bar.
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Every time you perform a file-related function on the document (open,
save, revert, and so on), XPert JobLog records the event, along with the
date and time, and the computer name on which the action took place.

To view the job log, choose Utilities > XPert JobLog.

Exporting the document report
To copy the contents of the dialog box to a newly created document,
click Report. You can then work with and save the report like any other
QuarkXPress document.
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What is XPert TextScaleShift?
The XPert TextScaleShift XTension displays a palette with controls that let
you apply horizontal/vertical scaling and baseline shift to highlighted text.

What XPert TextScaleShift adds to QuarkXPress
XPert TextScaleShift adds a command to the QuarkXPress View menu:
View > Show/Hide XPert TextScaleShift.

Using the TextScaleShift palette
To display the TextScaleShift palette, choose View > Show XPert
TextScaleShift. When the palette is displayed, choose View > Hide
XPert TextScaleShift to hide the palette.
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Using the palette to scale text
To apply horizontal or vertical scaling to text, first highlight the charac-
ters you want to modify.

Enter a scaling value in the Scale field (the field on the left side of the
palette). Scaling is measured as a percentage of actual scale; you can
enter values in .1- point increments

Click the icon to the left of the Scale field to specify whether the Scale
value you enter is applied as horizontal scaling or vertical scaling. When
you click the icon, the scale orientation and the palette’s Scale icon tog-
gle between Horizontal ( ) and Vertical ( ).

To apply the scaling to text, click on the document or press Enter.

Using the palette to apply baseline shift to text
To apply a baseline shift value to text, first highlight the characters you
want to shift.

To apply a specific baseline shift value, enter a value in the Baseline Shift
field (the field on the right side of the palette). You can enter values in
.01- point increments.

To apply baseline shift to characters visually, click the icon to the left of
the Baseline Shift field . Click the top of the icon to shift characters up
in 1-point increments; click the bottom of the icon to shift characters
down in 1-point increments.

To apply the baseline shift value to text, click on the document or
press Enter.
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What is XPert Preferences?
The XPert Preferences XTension adds three preference sets to Quark
XPress that let you: 1) control the resolution of the picture preview 
created when you import a picture, 2) customize the look of dialog boxes
and other QuarkXPress interface components, and 3) specify default
measurement units for different areas of the program.

What XPert Preferences adds to QuarkXPress
XPert Preferences adds three commands to the Edit menu’s Preferences
submenu: Edit > Preferences > Image, Edit > Preferences > Interface,
and Edit > Preferences > Measurements.
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Setting Image Preferences
To modify image preference settings, choose Edit > Preferences >
Image. The Image Preferences dialog box is displayed.

XPert Preferences lets you control the resolution of the picture preview
QuarkXPress creates and displays for a picture when you import it. Pic-
ture previews at higher resolution look nice on-screen, but result in
larger QuarkXPress files (as picture previews are saved as part of the
XPress document). Lower resolution picture previews don’t look as
good on-screen, but result in smaller files. High resolution preview pic-
tures can also slow down screen redraw. The resolution of a picture’s
QuarkXPress picture preview has no affect on the original picture file or
the way it prints from QuarkXPress.

To specify the import resolution of pictures you import at high resolu-
tion, enter a value between 1 and 300 in the Hi Resolution field.

To specify the import resolution of pictures you import at low resolu-
tion, enter a value between 1 and 300 in the Lo Resolution field.

The word “SHIFT” to the right of the dialog box fields indicates the reso-
lution at which a picture will be imported when the Shift key is down
(when you choose File > Get Picture to import a picture). By default,
pictures are imported at low resolution when the Shift key is down (and
at high resolution when Shift is not down). To reverse this preference so
that high resolution pictures are imported when the Shift key is down
(and at low resolution when Shift is not down) uncheck Shift Key for Lo
Res Import.

To reset the image preferences to their default values, click Reset.
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Setting Interface Preferences
To modify interface preference settings, choose Edit > Preferences >
Interface. The Interface Preferences dialog box is displayed.

Colorize
To change the color of one of the interface elements listed in the Col-
orize area, click the color swatch to the left of the element you want to
change. A standard color picker dialog box is displayed. Use the color
picker to choose the color you want, then click OK. The color swatches
display the currently selected colors for the corresponding interface
elements.

To change the color of the line that defines the outline of a document’s
electronic pages, click the color swatch to the left of Page Edge.

To change the color of page shadow cast by the electronic page on the
pasteboard, click the color swatch to the left of Page Shadow.

To add color shadows around dialog box area outlines, click the color
swatch to the left of Dialog Shadow.

To change the background color of dialog boxes, click the color swatch
to the left of Dialog Background.

Note: Use Dialog Colors (in the Gadgets area) must be checked for dia-
log shadows or background colors to display.
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This illustration shows a dialog shadows color and a dialog background applied. The
Use Dialog Color check box must be checked for the selected colors to display.

Gadgets
To add a graphic flourish to dialog box titles, check Flourish Dialogs.
(See the dialog box illustration below for an example of the flourishes
created by this feature.) 

To apply the colors for dialog box interface parts (Dialog Shadow and
Dialog Background) check Use Dialog Color. When unchecked, dialog
boxes will be displayed with the default, white background.

To change document window scroll bars so that they are solid gray and
have different-looking buttons, check Gray Scroll Bars.

This illustration shows examples of flourishes around the dialog box title, and color
shadows around the two dialog box areas.
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Setting Measurement Preferences
To modify measurement preference settings, choose Edit > Preferences
> Measurements. The Measurements Preferences dialog box is dis-
played. The measurement units you select in this dialog box determine
the default measurement units displayed in dialog box and Measure-
ment palette fields.

To change the default measurement unit displayed in font size fields,
choose a unit from the Font Size pop-up menu.

To change the default measurement unit displayed in leading fields,
choose a unit from the Leading pop-up menu.

To change the default measurement unit displayed in baseline shift
fields, choose a unit from the Baseline Shift pop-up menu.

To change the default measurement unit used to define a document’s
baseline grid, choose a unit from the Baseline Grid pop-up menu.

To change the default measurement unit displayed in text inset fields,
choose a unit from the Text Inset pop-up menu.

To change the default measurement unit displayed in text outset fields,
choose a unit from the Text Outset pop-up menu.

To change the default measurement unit displayed in line width fields,
choose a unit from the Line Width pop-up menu.

To change the default measurement unit used to specify trapping val-
ues, choose a unit from the Trap pop-up menu.
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What is XPert Greeking?
The XPert Greeking XTension lets you select individual pictures boxes for
greeking. The picture in a box to which you apply greeking displays as a
solid gray color when the box is not selected. When a greeked picture
box is active, its picture displays normally.

Because pictures contain a lot of data to display, they can slow you
down when you scroll through a document. By applying greeking to
picture boxes — especially to boxes that contain large color pictures —
you can dramatically increase the rate at which you can scroll through
QuarkXPress documents. XPert Greeking allows for more flexibility
than QuarkXPress’s global greeking feature, as you can apply greeking
selectively to only those large images that slow your scrolling.

The illustration shows a picture box to which greeking has been applied. When the box is
active (left), you can view the picture normally. When the box is not active (right), the
picture is grayed. The grayed area extends to the edges of the picture’s image area; notice
in the illustration that the image area does not extend to the edges of the picture box.

What XPert Greeking adds to QuarkXPress
XPert Greeking adds one command to the QuarkXPress menus.

• Item > Greek/Ungreek applies and removes the greek attribute from a
picture box. When a box to which the greek attribute is not currently
applied is selected, Greek is displayed in the Item menu; Ungreek 
displays when the current box has the greek attribute applied.
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Using XPert Greeking
To apply greeking to picture boxes, select the boxes you want to greek (you
can apply greeking to multiple selected picture boxes) and choose Item
> Greek. The box’s picture will be greeked when you deselect the box.

To remove greeking from picture boxes, select the boxes you want to ungreek
and choose Item > Ungreek. The box’s picture will display normally.
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